6-3 学生类

有一个学生类的结构如下: class Student { private int no; private String name; private int score; public Student(int _no, String _name, int _score) { no = _no; name = _name; score = _score; } public int getNo() {return no;} public String getName() {return name;} public int getScore() {return score;} public void print(){ System.out.println(no + " "+name+" "+score); } }

请构造main函数完成如下功能: 从键盘中读入三个学生的信息,比较他们的成绩,按照成绩由高到低排列输出

输入描述:

三个学生的学号、姓名、成绩

输出描述:

由高到低排列输出的三个学生信息

裁判测试程序样例:

/*你的代码被嵌在这里*/

class Student {
	private int no;
	private String name;
        private int score;
	
	public Student(int _no, String _name, int _score) {
		no = _no;
		name = _name;
                score = _score;
	}
        public int getNo() {return no;}
        public String getName() {return name;}
        public int getScore() {return score;}
	
	public void print(){
		System.out.println(no + " "+name+" "+score);
	}
}

输入样例:

在这里给出一组输入。例如:

1 wang 89
2 liu 78
3 ma 90

输出样例:

在这里给出相应的输出。例如:

3 ma 90
1 wang 89
2 liu 78

通过代码:

import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		Student s1 = new Student(sc.nextInt(), sc.next(), sc.nextInt());
		Student s2 = new Student(sc.nextInt(), sc.next(), sc.nextInt());
		Student s3 = new Student(sc.nextInt(), sc.next(), sc.nextInt());
		if(s1.getScore() >= s2.getScore() && s1.getScore() >= s3.getScore()) {
			s1.print();
			if(s2.getScore() >= s3.getScore()) {
				s2.print();
				s3.print();
			}
			else {
				s3.print();
				s2.print();
			}
		}
		else if(s2.getScore() >= s1.getScore() && s2.getScore() >= s3.getScore()) {
			s2.print();
			if(s1.getScore() >= s3.getScore()) {
				s1.print();
				s3.print();
			}
			else {
				s3.print();
				s1.print();
			}
		}
		else {
			s3.print();
			if(s1.getScore() >= s2.getScore()) {
				s1.print();
				s2.print();
			}
			else {
				s2.print();
				s1.print();
			}
		}
		sc.close();
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值