6-3 学生类 (20分)

6-3 学生类 (20分)

有一个学生类的结构如下:

/*你的代码被嵌在这里*/

class Student {
	private int no;
	private String name;
        private int score;
	
	public Student(int _no, String _name, int _score) {
		no = _no;
		name = _name;
                score = _score;
	}
        public int getNo() {return no;}
        public String getName() {return name;}
        public int getScore() {return score;}
	
	public void print(){
		System.out.println(no + " "+name+" "+score);
	}
}

请构造main函数完成如下功能: 从键盘中读入三个学生的信息,比较他们的成绩,按照成绩由高到低排列输出

输入描述:
三个学生的学号、姓名、成绩

输出描述:
由高到低排列输出的三个学生信息

输入样例:
在这里给出一组输入。例如:

1 wang 89
2 liu 78
3 ma 90

输出样例:
在这里给出相应的输出。例如:

3 ma 90
1 wang 89
2 liu 78

解决如下:

import java.util.Scanner;
public class Main {
	public static void main(String []args)
	{
		Scanner in = new Scanner(System.in);
		Student a = new Student(in.nextInt(),in.next(),in.nextInt());
		Student b = new Student(in.nextInt(),in.next(),in.nextInt());
		Student c = new Student(in.nextInt(),in.next(),in.nextInt());
		if(a.getScore()>b.getScore()&&a.getScore()>c.getScore())
			if(b.getScore()>c.getScore())
				{a.print();b.print();c.print();}
			else
				{a.print();c.print();b.print();}
		if(b.getScore()>a.getScore()&&b.getScore()>c.getScore())
			if(a.getScore()>c.getScore())
				{b.print();a.print();c.print();}
			else
				{b.print();c.print();a.print();}
		if(c.getScore()>b.getScore()&&c.getScore()>a.getScore())
			if(b.getScore()>a.getScore())
				{c.print();b.print();a.print();}
			else
				{c.print();a.print();b.print();}
		
	}
}

  • 1
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Solidare

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值