Eclipse提示JRE Oracle Corporation/14.0.2 is not supported, advanced source lookup disabled.

原来的JDK是1.8的,然后装了新的JDK14,执行代码时eclipse在控制台输出如下红句:

JRE Oracle Corporation/14.0.2 is not supported, advanced source lookup disabled.

 

发现这个eclipse支持的最好版本JDK是11: 

应该是eclipse版本太低的原因吧,所以去eclipse官网下最新的版本:

 

eclipse官网下载:https://www.eclipse.org/downloads/ 

如果原来的安装包还存着的话也可以用原来的安装包,它会提示你更新,然后就能装最新的eclipse了。

OK,享受在新的eclipse下用新的JDK吧!

©️2020 CSDN 皮肤主题: 游动-白 设计师:上身试试 返回首页