[C语言][树]Complete Binary Search Tree

1.题目

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

 

  • The left subtree of a node contains only nodes with keys less than the node's key.

     

     

  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.

     

     

  • Both the left and right subtrees must also be binary search trees.

     

    A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

    Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

    Output Specification:

    For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

    Sample Input:

    10
    1 2 3 4 5 6 7 8 9 0
    

    Sample Output:

    6 3 8 1 5 7 9 0 2 4

2.代码

#include<stdio.h>
#include<stdlib.h>
#include<stack>
#include<queue>
#include<math.h>
#define Maxsize 1001
using namespace std;
int a[Maxsize];
int t[Maxsize];//树
int n;
int cmp(const void*a,const void*b)
{
    return *(int*)a-*(int*)b;
}
int getleft(int n)
{
    int h,x,l;
    h=(int)log2(n+1);
    x=n-pow(2,h)+1;
    x=x>pow(2,h-1)?pow(2,h-1):x;
    l=pow(2,h-1)-1+x;
    return l;

}
void solve(int aleft,int aright,int root)
{
    int len,Llen,leftroot,rightroot;
    len=aright-aleft+1;
    if(len==0) return;
    Llen=getleft(len);//n个节点左子树应该有多少个节点
    t[root]=a[Llen+aleft];
    leftroot=root*2+1;
    rightroot=leftroot+1;
    solve(aleft,aleft+Llen-1,leftroot);
    solve(aleft+Llen+1,aright,rightroot);
}
int main()
{
    scanf("%d",&n);
    int i;
    for(i=0;i<n;i++)
        scanf("%d",&a[i]);
    qsort(a,n,sizeof(int),cmp);
    solve(0,n-1,0);
    int flag=0;
    for(i=0;i<n;i++)
    {
        if(flag==0)
        {
                printf("%d",t[i]);
                flag=1;
        }
        else
        {
            printf(" %d",t[i]);
        }
    }
    printf("\n");
}

 3.分析

题目的意思是构建一个完全搜索树,也就是一棵完全二叉树,又是搜索树。假如按照这样的想法,先建立一棵完全二叉树,然后再调整为搜索树,是十分麻烦的。我们知道搜索树的特点,可以利用这一点,递归更新根节点的值。先给数组排序,然后我们求得左子树的节点个数,就可以知道根节点的值是多少了。然后递归的求解。

关于左子树的节点个数:由于是完全二叉树,也比较好求解,如下:

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值