Almost Sorted Array(UVALive 7188)

Description

We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection
sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted array.
We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We
say an array is almost sorted if we can remove exactly one element from it, and the remaining array is
sorted. Now you are given an array a1, a2, …, an, is it almost sorted?
Input
The first line contains an integer T indicating the total number of test cases. Each test case starts with
an integer n in one line, then one line with n integers a1, a2, …, an.
• 1 ≤ T ≤ 2000
• 2 ≤ n ≤ 105
• 1 ≤ ai ≤ 105
• There are at most 20 test cases with n > 1000.

Output

For each test case, please output ‘YES’ if it is almost sorted. Otherwise, output ‘NO’ (both without
quotes).

Sample Input

3
3
2 1 7
3
3 2 1
5
3 1 4 1 5

Sample Output

YES
YES
NO

题解:

最长上升子序列模板题,因为可能有升序或者降序两种情况,所以正反都找一遍。

代码如下:

#include<algorithm>
#include<iostream>
#include<cstdlib>
#include<cstring>
#include<cstdio>
#include<string>
#include<vector>
#include<cmath>
#include<stack>
#include<queue>
#include<map>
#include<set>
#define max(a,b)   (a>b?a:b)
#define min(a,b)   (a<b?a:b)
#define swap(a,b)  (a=a+b,b=a-b,a=a-b)
#define maxn 27
#define N 100000000
#define INF 0x3f3f3f3f
#define mod 1001113
#define e  2.718281828459045
#define eps 1.0e18
#define PI acos(-1)
#define lowbit(x) (x&(-x))
#define read(x) scanf("%d",&x)
#define put(x) prllf("%d\n",x)
#define memset(x,y) memset(x,y,sizeof(x))
#define Debug(x) cout<<x<<" "<<endl
#define lson i << 1,l,m
#define rson i << 1 | 1,m + 1,r
#define ll long long
//std::ios::sync_with_stdio(false);
//cin.tie(NULL);
//const int maxn=;
using namespace std;

int a[100007],b[100007],low[100007],low1[100007],n;

int binary_search(int r,int x)
{
    int l=1,mid;
    while(l<=r)
    {
        mid=(l+r)>>1;
        if(a[mid]<=x)
            l=mid+1;
        else
            r=mid-1;
    }
    return l;
}
int binary_search1(int r,int x)
{
    int l=1,mid;
    while(l<=r)
    {
        mid=(l+r)>>1;
        if(b[mid]<=x)
            l=mid+1;
        else
            r=mid-1;
    }
    return l;
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        cin>>n;
        for(int i=1; i<=n; i++)
        {
            cin>>a[i];
            b[n-i+1]=a[i];
            low[i]=low1[i]=INF;
        }
        low[1]=a[1];
        low1[1]=b[1];
        int ans=1;
        int ans1=1;
        for(int i=2; i<=n; i++)
        {
            if(a[i]>=low[ans])
                low[++ans]=a[i];
            else
                low[binary_search(ans,a[i])]=a[i];
        }
        for(int i=2; i<=n; i++)
        {
            if(b[i]>=low1[ans1])
                low1[++ans1]=b[i];
            else
                low1[binary_search1(ans1,b[i])]=b[i];
        }
        if(ans>=n-1||ans1>=n-1)
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
        memset(a,0);
        memset(b,0);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值