UPC 9260: Almost Sorted Array

题目描述

We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an  overkill to use these algorithms for an almost sorted array.
We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it, and the remaining array is sorted. Now you are given an array a1 , a2 , . . . , an , is it almost sorted?

 

输入

The first line contains an integer T indicating the total number of test cases. Each test case starts with an integer
n in one line, then one line with n integers a1 , a2 , . . . , an .
1≤T≤2000
2≤n≤105
1≤a i≤105
There are at most 20 test cases with n > 1000.

 

输出

For each test case, please output ”‘YES‘” if it is almost sorted. Otherwise, output ”‘NO‘” (both without quotes).

 

样例输入

3
3
2 1 7
3
3 2 1
5
3 1 4 1 5

 

样例输出

YES
YES
NO

题意:给定数列,删除一个元素,数列是否可以成为单调数列?

思路:按递减数列排序,查看有几个不满足的数并标记其位置,若没有则可以,多余一个则不可以,等于一个是需要看去掉此元素或去掉它前面的一个元素是否可以。

按递增数列排序同上……

#include<bits/stdc++.h>
using namespace std;
#define ll long long int
#define INF 0x3f3f3f3f
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        int a[100010];
        scanf("%d",&n);
        int cnt=0,cnt1=0;
        int num=0,num1=0;
        int temp=1,temp1=1;
        scanf("%d",&a[0]);
        for(int i=1; i<n; i++)
        {
            scanf("%d",&a[i]);
            if(a[i]>=a[i-1])//递增数列
            {
                cnt++;
            }
            else
            {
                temp=i;//记录位置
                num++;
            }
            if(a[i]<=a[i-1])//递减数列
            {
                cnt1++;
            }
            else
            {
                temp1=i
                num1++;
            }

        }
        if(cnt==n-1||cnt1==n-1||(num==1&&(temp==1||temp==n-1||a[temp-1]<=a[temp+1]||a[temp-2]<=a[temp]))||(num1==1&&(temp1==1||temp1==n-1||a[temp1-1]>=a[temp1+1]||a[temp1-2]>=a[temp1])))
            printf("YES\n");
        else
            printf("NO\n");

    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值