Bazinga

Description

Ladies and gentlemen, please sit up straight.
Don’t tilt your head. I’m serious.

For n given strings S1, S2, · · · , Sn, labelled from 1 to n, you should find the largest i (1 ≤ i ≤ n) such that there exists an integer j (1 ≤ j < i) and Sj is not a substring of Si.
A substring of a string Si is another string that occurs in Si. For example, “ruiz” is a substring of “ruizhang”, and “rzhang” is not a substring of “ruizhang”.

Input

The first line contains an integer t (1 ≤ t ≤ 50) which is the number of test cases. For each test case, the first line is the positive integer n (1 ≤ n ≤ 500) and in the following n lines list are the strings S1, S2, · · · , Sn. All strings are given in lower-case letters and strings are no longer than 2000 letters.

Output

For each test case, output the largest label you get. If it does not exist, output ‘-1’.

Sample Input

4
5
ab
abc
zabc
abcd
zabcd
4
you
lovinyou
aboutlovinyou
allaboutlovinyou 
5
de
def
abcd
abcde
abcdef 
3
a
ba
ccc

Sample Output

Case #1: 4
Case #2: -1
Case #3: 4
Case #4: 3

题解:

查找前串不是其子串的串,输出其序号,若没有,输出-1。因为串比较大,用kmp算法比较好。

代码如下:

#include<algorithm>
#include<iostream>
#include<cstdlib>
#include<cstring>
#include<cstdio>
#include<string>
#include<vector>
#include<cmath>
#include<stack>
#include<queue>
#include<map>
#include<set>
#define max(a,b)   (a>b?a:b)
#define min(a,b)   (a<b?a:b)
#define swap(a,b)  (a=a+b,b=a-b,a=a-b)
#define maxn 100007
#define N 100000000
#define INF 0x3f3f3f3f
#define mod 1001113
//#define e  2.718281828459045
#define eps 1.0e18
#define PI acos(-1)
#define lowbit(x) (x&(-x))
#define read(x) scanf("%d",&x)
#define put(x) prllf("%d\n",x)
#define memset(x,y) memset(x,y,sizeof(x))
#define Debug(x) cout<<x<<" "<<endl
#define lson i << 1,l,m
#define rson i << 1 | 1,m + 1,r
#define ll long long
//std::ios::sync_with_stdio(false);
//cin.tie(NULL);
//const int maxn=;
using namespace std;

char a[507][2007];
int b[507];

int kmp(int p,int q)
{
    int l=strlen(a[p]),ls=strlen(a[q]);
    int i=0,j=0;
    while(i<l&&j<ls)
    {
        if(a[p][i]==a[q][j])
        {
            i++;
            j++;
        }
        else
        {
            i=i-j+1;
            j=0;
        }
    }
    if(j==ls)
        return i-j;
    return -1;
}

int main()
{
    int t,s=1;
    cin>>t;
    while(t--)
    {
        int n;
        cin>>n;
        int k=0;
        memset(b,0);
        for(int i=1;i<=n;i++)
        {
            cin>>a[i];
            for(int j=i-1; j>=1; j--)
            {
                if(b[j]!=0)
                    continue;
                if(kmp(i,j)==-1)
                {
                    k=i;
                    break;
                }
                else
                    b[j]=1;
            }
        }
        if(!k)
            cout<<"Case #"<<s++<<": -1"<<endl;
        else
            cout<<"Case #"<<s++<<": "<<k<<endl;
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值