HDU ACM1031——Design T-Shirt

41 篇文章 0 订阅
3 篇文章 0 订阅

Design T-Shirt

Problem Description

Soon after he decided to design a T-shirt for our Algorithm Board on Free-City BBS, XKA found that he was trapped by all kinds of suggestions from everyone on the board. It is indeed a mission-impossible to have everybody perfectly satisfied. So he took a poll to collect people’s opinions. Here are what he obtained: N people voted for M design elements (such as the ACM-ICPC logo, big names in computer science, well-known graphs, etc.). Everyone assigned each element a number of satisfaction. However, XKA can only put K (<=M) elements into his design. He needs you to pick for him the K elements such that the total number of satisfaction is maximized.

Input

The input consists of multiple test cases. For each case, the first line contains three positive integers N, M and K where N is the number of people, M is the number of design elements, and K is the number of elements XKA will put into his design. Then N lines follow, each contains M numbers. The j-th number in the i-th line represents the i-th person’s satisfaction on the j-th element.

Output

For each test case, print in one line the indices of the K elements you would suggest XKA to take into consideration so that the total number of satisfaction is maximized. If there are more than one solutions, you must output the one with minimal indices. The indices start from 1 and must be printed in non-increasing order. There must be exactly one space between two adjacent indices, and no extra space at the end of the line.

Sample Input

3 6 4
2 2.5 5 1 3 4
5 1 3.5 2 2 2
1 1 1 1 1 10
3 3 2
1 2 3
2 3 1
3 1 2

Sample Output

6 5 3 1
2 1

题目大意:N个人对M个元素有不同的满意度,XKA的工作就是在其中找所有人满意度总合最大的前K个元素,并把它们的序号按非升序输出。
题解:首先求出每个元素的总满意度,之后找出最大的前K个,并记录其序号,之后将序号按非升序输出即可。

#include<stdio.h>
int n,m,k,p,q,i,j;
int main()
{
	while(scanf("%d %d %d",&n,&m,&k)!=EOF)
	{	
		double b[999]={0};	/*存放所有人对第j个元素的满意度之和*/
		double a[99][999];	/*存放每个人对第j个元素的满意度*/ 
		int con[99];	/*存放前K个满意度最大的元素的索引(序号)*/ 
		for(i=0;i<n;i++){	/*输入*/ 
			for(j=0;j<m;j++){
				scanf("%lf",&a[i][j]);
				b[j]+=a[i][j];
			}
		}
		q=0;
		for(j=0;j<k;j++){	/*找寻前K个满意度最大的元素并赋值*/ 
			int max=-10;
			for(i=m-1;i>=0;i--){
				if(max<=b[i]){
					max=b[i];
					p=i;
				}
			}
			b[p]=-999;	/*防止重复查找*/ 
			con[q++]=p+1;	
		}
		for(i=0;i<k-1;i++){	/*对索引进行排序*/ 
			for(j=0;j<k-1-i;j++){
				if(con[j]<con[j+1]){
					p=con[j];
					con[j]=con[j+1];
					con[j+1]=p;
				}
			}
		}
		for(i=0;i<k;i++){	/*输出索引*/ 
			printf("%d",con[i]);
			if(i==(k-1))printf("\n");
			else printf(" ");
		}
	}
	return 0;
 } 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值