poj2926 2010.2.26

poj2926 2010.2.26

Requirements

Time Limit: 5000MS  Memory Limit: 65536K

Total Submissions: 2926  Accepted: 846

 

Description

 

An undergraduate student, realizing that heneeds to do research to improve his chances of being accepted to graduateschool, decided that it is now time to do some independent research. Of course,he has decided to do research in the most important domain: the requirements hemust fulfill to graduate from his undergraduate university. First, hediscovered (to his surprise) that he has to fulfill 5 distinct requirements:the general institute requirement, the writing requirement, the sciencerequirement, the foreign-language requirement, and the field-of-specializationrequirement. Formally, a requirement is a fixed number of classes that he hasto take during his undergraduate years. Thus, for example, the foreign languagerequirement specifies that the student has to take 4 classes to fulfill thisrequirement: French I, French II, French III, and French IV. Having analyzedthe immense multitude of the classes that need to be taken to fulfill thedifferent requirements, our student became a little depressed about hisundergraduate university: there are so many classes to take…

 

Dejected, the student began studying therequirements of other universities that he might have chosen after high school.He found that, in fact, other universities had exactly the same 5 requirementsas his own university. The only difference was that different universities haddifferent number of classes to be satisfied in each of the five requirement.

 

Still, it appeared that universities havepretty similar requirements (all of them require a lot of classes), so hehypothesized that no two universities are very dissimilar in theirrequirements. He defined the dissimilarity of two universities X and Y as |x1 −y1| + |x2 − y2| + |x3 − y3| + |x4 − y4| + |x5 − y5|, where an xi (yi) is thenumber of classes in the requirement i of university X (Y) multiplied by anappropriate factor that measures hardness of the corresponding requirement atthe corresponding university.

 

Input

 

The first line of the input file containsan integer N (1 ≤ N ≤ 100 000), the number of considered universities. The following Nlines each describe the requirements of a university. A university X isdescribed by the five non-negative real numbers x1 x2 x3 x4 x5.

 

Output

 

On a single line, print the dissimilarityvalue of the two most dissimilar universities. Your answer should be rounded toexactly two decimal places.

 

Sample Input

 

3

2 5 6 2 1.5

1.2 3 2 5 4

7 5 3 2 5

Sample Output

 

12.80

Source

 

MIT Programming Contest 2005


#include <cstdio>
#include <cstring>

#define N 100000+10

double data[N][5],list[N];
int n;

int main()
{
	scanf("%d",&n);
	for(int i=1;i<=n;i++)
		scanf("%lf %lf %lf %lf %lf",data[i],data[i]+1,data[i]+2,data[i]+3,data[i]+4);
	double maxsub=0;
	for(int k=0;k<32;k++)
	{
		double max=-1e250,min=1e250;
		for(int i=1;i<=n;i++)
		{
			double sum=((k&1)?data[i][0]:-data[i][0])
				+((k&2)?data[i][1]:-data[i][1])
				+((k&4)?data[i][2]:-data[i][2])
				+((k&8)?data[i][3]:-data[i][3])
				+((k&16)?data[i][4]:-data[i][4]);
//用按位与看哪位上是1,0
			max=sum>max?sum:max;
			min=sum<min?sum:min;
		}
		maxsub=(max-min)>maxsub?(max-min):maxsub;
	}
	printf("%.2lf\n",maxsub);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值