hdu2275 2010.3.6

hdu2275 2010.3.6

第一次使用set容器

 

hdu 2275

 

Kiki & Little Kiki 1

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 310    Accepted Submission(s): 97

 

 

Problem Description

Kiki is considered as a smart girl in HDU,many boys fall in love with her! Now, kiki will finish her education, and leaveschool, what a pity! One day, zjt meets a girl, who is like kiki very much, inthe campus, and calls her little kiki. Now, little kiki want to design acontainer, which has two kinds of operation, push operation, and pop operation.

Push M:

 Push the integer M into the container.

Pop M:

 Find the maximal integer, which is not bigger than M, in the container.And pop it from the container. Specially, for all pop operations, M[i] is nobigger than M[i+1].

Although she is as smart as kiki, she stillcan't solve this problem! zjt is so busy, he let you to help little kiki tosolve the problem. Can you solve the problem?

 

 

 

 

Input

The input contains one or more data sets.At first line of each input data set is an integer N (1<= N <= 100000)indicate the number of operations. Then N lines follows, each line contains aword (“Push” or “Pop”) and an integer M. The word “Push” means a pushoperation, while “Pop” means a pop operation. You may assume all the numbers inthe input file will be in the range of 32-bit integer.

 

 

Output

For each pop operation, you should printthe integer satisfy the condition. If there is no integer to pop, please print“No Element!”. Please print a blank line after each data set.

 

 

Sample Input

9

Push 10

Push 20

Pop 2

Pop 10

Push 5

Push 2

Pop 10

Pop 11

Pop 19

3

Push 2

Push 5

Pop 2

 

 

Sample Output

No Element!

10

5

2

No Element!

 

2

 

 

Source

HDU 8th Programming Contest Site(1)

 

 

Recommend

lcy


#include<cstdio>
#include<set>
using namespace std;

int main()
{
int n,i,m;
char a[10];

for(;;)
{
multiset<int>S;//容器
        multiset<int>::iterator p,q;//迭代器
  
if(scanf("%d",&n)==EOF) break;
for(i=0;i<n;i++)
{
scanf("%s%d",a,&m);
if(a[3]=='h') S.insert(m);
else 
{
p=S.begin();
if(*p>m)
                {
                    printf("No Element!\n");continue;
                }
p=S.find(m);
                if(p!=S.end())
                {
                    printf("%d\n",*p);S.erase(p);//删除
                }
else
                {
                    S.insert(m);p=q=S.find(m);p--;
                    printf("%d\n",*p);
                    S.erase(p);S.erase(q);
                }
}
}
printf("\n");
}
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值