HDU2275-Kiki & Little Kiki 1

216 篇文章 0 订阅
100 篇文章 0 订阅

Kiki & Little Kiki 1

                                                                              Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                                                          Total Submission(s): 1144    Accepted Submission(s): 405


Problem Description
Kiki is considered as a smart girl in HDU, many boys fall in love with her! Now, kiki will finish her education, and leave school, what a pity! One day, zjt meets a girl, who is like kiki very much, in the campus, and calls her little kiki. Now, little kiki want to design a container, which has two kinds of operation, push operation, and pop operation. 
Push M: 
  Push the integer M into the container.
Pop M:
  Find the maximal integer, which is not bigger than M, in the container. And pop it from the container. Specially, for all pop operations, M[i] is no bigger than M[i+1].
Although she is as smart as kiki, she still can't solve this problem! zjt is so busy, he let you to help little kiki to solve the problem. Can you solve the problem?

 

Input
The input contains one or more data sets. At first line of each input data set is an integer N (1<= N <= 100000) indicate the number of operations. Then N lines follows, each line contains a word (“Push” or “Pop”) and an integer M. The word “Push” means a push operation, while “Pop” means a pop operation. You may assume all the numbers in the input file will be in the range of 32-bit integer.
 

Output
For each pop operation, you should print the integer satisfy the condition. If there is no integer to pop, please print “No Element!”. Please print a blank line after each data set.
 

Sample Input
  
  
9 Push 10 Push 20 Pop 2 Pop 10 Push 5 Push 2 Pop 10 Pop 11 Pop 19 3 Push 2 Push 5 Pop 2
 

Sample Output
  
  
No Element! 10 5 2 No Element! 2
 

Source
 

题意:有n个命令,Push是压入数字m,Pop则是找到第一个不大于m的数,并移出来,若找不到则输出No Elenment!


#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <stack>
#include <vector>
#include <set>
#include <map>

using namespace std;

multiset<int>s;
multiset<int>::iterator it1,it2;

int main()
{
    int n,x;
    char ch[10];
    while(~scanf("%d",&n))
    {
        s.clear();
        while(n--)
        {
            scanf("%s %d",ch,&x);
            if(ch[1]=='u') s.insert(x);
            else
            {
                if(x<*(s.begin()))
                {
                    printf("No Element!\n");
                    continue;
                }
                it1=s.find(x);
                if(it1!=s.end())
                {
                    printf("%d\n",*it1);
                    s.erase(it1);
                }
                else
                {
                    s.insert(x);
                    it1=it2=s.find(x);
                    it1--;
                    printf("%d\n",*it1);
                    s.erase(it1);
                    s.erase(it2);
                }
            }
        }
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值