HDOJ 2058 The sum problem【水题】

Problem Description
Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.

Input
Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.

Output
For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.

Sample Input
  
  
20 10 50 30 0 0

Sample Output
  
  
[1,4] [10,10] [4,8] [6,9] [9,11] [30,30]
------------------------------------------------------------------------------------------------------------------------------------
#include <iostream>
#include <math.h>
using namespace std;
int main()
{
    __int64 m ,n;
    while(cin>>n>>m,n||m)
    {
        __int64 a,k;
        for(k=(int)sqrt(2*m);k>0;k--)//因为1+2+。。。+(2*m)^1/2>m;所一和为m的元素个数应该小于等于(2*m)^1/2;
        {
            a=m/k-(k-1)/2;//假设从a开始一直加到a+k-1,一共k个元素和为m,可以计算出a;
            if((2*a-1+k)*k==2*m) //(2*m)^1/2可能不是整数,判断是有必要的;
                cout<<"["<<a<<","<<k+a-1<<"]"<<endl;
        }
cout<<endl;

    }
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值