POJ 1743 Musical Theme 【后缀数组】最长不可重叠子串

Description

A musical melody is represented as a sequence of N (1<=N<=20000)notes that are integers in the range 1..88, each representing a key on the piano. It is unfortunate but true that this representation of melodies ignores the notion of musical timing; but, this programming task is about notes and not timings. 
Many composers structure their music around a repeating &qout;theme&qout;, which, being a subsequence of an entire melody, is a sequence of integers in our representation. A subsequence of a melody is a theme if it: 
  • is at least five notes long 
  • appears (potentially transposed -- see below) again somewhere else in the piece of music 
  • is disjoint from (i.e., non-overlapping with) at least one of its other appearance(s)

Transposed means that a constant positive or negative value is added to every note value in the theme subsequence. 
Given a melody, compute the length (number of notes) of the longest theme. 
One second time limit for this problem's solutions! 

Input

The input contains several test cases. The first line of each test case contains the integer N. The following n integers represent the sequence of notes. 
The last test case is followed by one zero. 

Output

For each test case, the output file should contain a single line with a single integer that represents the length of the longest theme. If there are no themes, output 0.

Sample Input

30
25 27 30 34 39 45 52 60 69 79 69 60 52 45 39 34 30 26 22 18
82 78 74 70 66 67 64 60 65 80
0

Sample Output

5

Hint

Use scanf instead of cin to reduce the read time.




/*
    POJ 1743 Musical Theme
    题意:有N个音符的序列来表示一首乐曲,每个音符都是1..88范围内的整数,现在要找一个最长的主题.
          "主题"是整个音符序列的一个子串,它需要满足如下条件:
            1.长度至少为5个音符
            2.在乐曲中重复出现(可能经过转调,"转调"的意思是主题序列中每个音符都被加上或减去了同一个整数值)
            3.重复出现的同一主题不能有公共部分

    分析样例:30
              25 27 30 34 39 45 52 60 69 79 69 60 52 45 39 34 30 26 22 18 82 78 74 70 66 67 64 60 65 80
              在上面的序列,经过分析发现{34 30 26 22 18}和{82 78 74 70 66}可以满足主题,
              因为{34 30 26 22 18}全部值加上48就会等于{82 78 74 70 66},并且这个主题是在上面是最长的
              所以答案输出为5.

    类型:后缀数组+二分

    分析:1.首先要知道怎么判断两个子串是否为同一主题,方法就是分析两个子串相邻两个字符的差值,当差值相同的时候,
          两个子串其中一个可以通过加减同一个整数值使得这部分与另一个子串相同.
          2.其次就是怎么找最长的不可重叠重复子串,找最长的不可重叠重复子串的做法就是
          先进行二分答案,把题目转化成判定性问题:判断是否存在两个长度为k的子串是相同的,且不重叠.
          利用后缀数组的height[],把排好序的后缀分成若干组,其中每组的后缀之间的height值都不小于k.
          然后对每组后缀,只需判断每个后缀的sa值的最大值和最小值之差是否>=k,如果满足,则存在,否则不存在.
          最后得到的k就是最大长度,再判断是否满足第一个条件(长度至少为5个音符)即可.

    相关算法:suffix array (SA) 倍增算法 O(n*logn)
              待排序数组长度为n,放在0~n-1中,在最后面补一个0
              例如 n = 5
                   i = { 0, 1, 2, 3, 4, 5 }
                   a = { 1, 1, 1, 2, 2, 0 };注意a最后一位补一个0下去
                rank = { 1, 2, 3, 5, 4, \ };rank[i]表示以i为下标的后缀排在第几,取值范围[0~n-1],rank[n]为无效值
                  sa = { \, 0, 1, 2, 4, 3 };sa[i]表示排在第i名的下标是多少,取值范围[1~n],sa[0]为n无效值
              height = { \, \, 2, 1, 0, 1 };height[i]表示排在i-1名与排在第i名的最长公共前缀,取值范围[2~n]
*/
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int MAXN=20010;
int sa[MAXN];//sa[i]表示排在第i名的下标是多少,取值范围[1~n]
int rank[MAXN];//rank[i]表示以i为下标的后缀排在第几,取值范围[0~n-1]
int height[MAXN];//height[i]表示排在i-1名与排在第i名的最长公共前缀,取值范围[2~n]
int t1[MAXN],t2[MAXN],c[MAXN];//求sa数组需要的中间变量,不需要赋值初始化
int s[MAXN];
//待排序的字符串放在s数组中,从s[0]到s[n-1],长度为n,且最大值小于m.
//除s[n]为0 外的所有s[i]都大于0;函数结束以后结果放在sa数组中
void build_sa(int s[],int n,int m) //得到SA数组
{
    int i,j,p,*x=t1,*y=t2;
    for(i=0;i<m;i++)c[i]=0;
    for(i=0;i<n;i++)c[x[i]=s[i]]++;
    for(i=1;i<m;i++)c[i]+=c[i-1];
    for(i=n-1;i>=0;i--)sa[--c[x[i]]]=i;
    for(j=1;j<=n;j<<=1){
        p=0;
        for(i=n-j;i<n;i++)y[p++]=i;
        for(i=0;i<n;i++)if(sa[i]>=j)y[p++]=sa[i]-j;
        for(i=0;i<m;i++)c[i]=0;
        for(i=0;i<n;i++)c[x[y[i]]]++;
        for(i=1;i<m;i++)c[i]+=c[i-1];
        for(i=n-1;i>=0;i--)sa[--c[x[y[i]]]]=y[i];
        swap(x,y);
        p=1;x[sa[0]]=0;
        for(i=1;i<n;i++)
            x[sa[i]]=y[sa[i-1]]==y[sa[i]] && y[sa[i-1]+j]==y[sa[i]+j]?p-1:p++;
        if(p>=n)break;
        m=p;
    }
}
void getHeight(int s[],int n){ //得到height数组
    int i,j,k=0;
    for(i=0;i<=n;i++)rank[sa[i]]=i;
    for(i=0;i<n;i++){
        if(k)k--;
        j=sa[rank[i]-1];
        while(s[i+k]==s[j+k])k++;
        height[rank[i]]=k;
    }
}

bool check(int n,int k)//判断每组中 每个后缀的sa值的最大值和最小值之差是否>=k
{
    int Max=sa[1],Min=sa[1];
    for(int i=2;i<=n;i++)
    {
        if(height[i]<k)Max=Min=sa[i];
        else
        {
            if(sa[i]<Min)Min=sa[i];
            if(sa[i]>Max)Max=sa[i];
            if(Max-Min>k)return true;
        }
    }
    return false;
}
int main()
{
    //freopen("F:\\input.txt","r",stdin);
    int n;
    while(scanf("%d",&n)==1 && n)
    {
        for(int i=0;i<n;i++)scanf("%d",&s[i]);
        for(int i=n-1;i>0;i--)  //相邻两项的差相同+90也是相同的,+90是防止出现负数
            s[i]=s[i]-s[i-1]+90;
        n--;                    //减少一个长度,因为差项个数比原来序列少了1
        for(int i=0;i<n;i++)    //调整新的序列
            s[i]=s[i+1];
        s[n]=0;                 //s[n]置为0
        build_sa(s,n+1,200);
        getHeight(s,n);
        int ans=-1;
        int l=1,r=n/2;          //k最大不可能超过序列的一半,所以可以r=n/2
        while(l<=r)             //二分组数k
        {
            int mid=(l+r)/2;
            if(check(n,mid))
            {
                ans=mid;
                l=mid+1;
            }
            else r=mid-1;
        }
        if(ans<4)printf("0\n"); //以4作判定条件1是因为这里处理的是差的序列,当有4个差能构成主题,原串就有5个能构成主题
        else printf("%d\n",ans+1);
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值