POJ 1743 Musical Theme 后缀数组 二分

A musical melody is represented as a sequence of N (1<=N<=20000)notes that are integers in the range 1..88, each representing a key on the piano. It is unfortunate but true that this representation of melodies ignores the notion of musical timing; but, this programming task is about notes and not timings. 
Many composers structure their music around a repeating &qout;theme&qout;, which, being a subsequence of an entire melody, is a sequence of integers in our representation. A subsequence of a melody is a theme if it: 
  • is at least five notes long 
  • appears (potentially transposed -- see below) again somewhere else in the piece of music 
  • is disjoint from (i.e., non-overlapping with) at least one of its other appearance(s)

Transposed means that a constant positive or negative value is added to every note value in the theme subsequence. 
Given a melody, compute the length (number of notes) of the longest theme. 
One second time limit for this problem's solutions! 
Input
The input contains several test cases. The first line of each test case contains the integer N. The following n integers represent the sequence of notes. 
The last test case is followed by one zero. 
Output
For each test case, the output file should contain a single line with a single integer that represents the length of the longest theme. If there are no themes, output 0.
Sample Input
30
25 27 30 34 39 45 52 60 69 79 69 60 52 45 39 34 30 26 22 18
82 78 74 70 66 67 64 60 65 80
0
Sample Output
5
Hint
Use scanf instead of cin to reduce the read time.


差不多可以说是一个后缀数组的板题了。

好吧,用我自己的那个归并排序的写法会TLE,但是道理上是一样的。。

因为这个题目要求的是找到一个最长的不重叠子串,二分一个长度len,判定height数组里面是不是有一组后缀的height大于等于len且最大位置大于等于最小位置+len

交了许多次才AC。。。慢慢地就会变好的。。

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>

const int maxm=20010;

int n,wa[maxm],ws[maxm],wv[maxm],arr[maxm],wb[maxm],raw[maxm],sa[maxm],*x,*y,height[maxm],_rank[maxm],ans;

void da(),calheight();
inline bool cmp(int* r,int a,int b,int L){return r[a]==r[b]&&r[a+L]==r[b+L];};
inline bool cmp1(int a,int b){return x[a]<x[b];}
bool judge(int len);
template <typename T>T max(const T& a,const T& b,const T& c){return std::max(a,std::max(b,c));}
template <typename T>T min(const T& a,const T& b,const T& c){return std::min(a,std::min(b,c));}

int main(){
    using namespace std;
    ios_base::sync_with_stdio(0);
    while(cin>>n&&n){
        if(n<10){
            for(int i=0;i<n;++i)
                cin>>arr[0];
            cout<<0<<endl;
            continue;
        }
        cin>>arr[0];
        for(int i=1;i<n;++i){
            cin>>arr[i];
            raw[i-1]=arr[i-1]-arr[i]+100;
        }

        da();
        calheight();

        int ri=n,le=1;
        while(ri>le+1)(judge((le+ri)>>1)?le:ri)=((le+ri)>>1);
        ans=(le==ri||judge(ri)?ri:le);
        cout<<(ans>=4?ans+1:0)<<endl;
    }
    return 0;
}

void da(){
    int m=200,i,j,p;
    x=wa,y=wb;

    memset(ws,0,sizeof ws);
    for(i=0;i<n;++i)ws[x[i]=raw[i]]++;
    for(i=1;i<m;++i)ws[i]+=ws[i-1];
    for(i=n-1;i>=0;--i)sa[--ws[x[i]]]=i;
    for(j=1,p=1;p<n;j<<=1,m=p){

        for(p=0,i=n-j;i<n;++i)y[p++]=i;
        for(i=0;i<n;++i)if(sa[i]>=j)y[p++]=sa[i]-j;
        for(i=0;i<n;++i)wv[i]=x[y[i]];
        memset(ws,0,sizeof ws);
        for(i=0;i<n;++i)ws[wv[i]]++;
        for(i=1;i<m;++i)ws[i]+=ws[i-1];
        for(i=n-1;i>=0;--i)sa[--ws[wv[i]]]=y[i];
        for(std::swap(x,y),p=1,x[sa[0]]=0,i=1;i<n;++i)
        x[sa[i]]=cmp(y,sa[i-1],sa[i],j)?p-1:p++;
    }
}


void calheight(){
    for(int i=1;i<n;++i)_rank[sa[i]]=i;
    for(int i=0,j,k=0;i<n;height[_rank[i++]]=k)
    for(k?k--:0,j=sa[_rank[i]-1];raw[i+k]==raw[j+k];++k);
}

bool judge(int len){
    int le=0x3f3f3f3f,ri=-0x3f3f3f3f;
    for(int i=1;i<n;++i)
    if(height[i]>=len)
        le=min(le,sa[i],sa[i-1]),ri=max(ri,sa[i],sa[i-1]);
    else{
        if(ri>=le+len)
            return true;
        ri=-(le=0x3f3f3f3f);
    }
    return ri>=le+len;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值