【HDU】-4006-The kth great number(优先队列,好)

The kth great number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 9936    Accepted Submission(s): 3960


Problem Description
Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
 

Input
There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number. 
 

Output
The output consists of one integer representing the largest number of islands that all lie on one line. 
 

Sample Input
  
  
8 3 I 1 I 2 I 3 Q I 5 Q I 4 Q
 

Sample Output
  
  
1 2 3
题意:n个数分拨输入,遇Q输出里面第m大的元素。

题解:始终保持队列里有m个元素即可,如果下一个元素大于最大的,加进来,把最小的弹出。如果不大于,加进了没有意义,不要,继续。

#include<cstdio>
#include<queue>
#include<algorithm>
using namespace std;
struct node
{
	int num;
	bool friend operator < (node a,node b)
	{
		return a.num>b.num;				//数字从小往大排序,小先进,大后进 (先进先出)
	}
}a;
int main()
{
	int n,m;
	char c;
	int ant;
	while(~scanf("%d %d",&n,&m))
	{
		ant=0;
		priority_queue<node> q;
		for(int i=1;i<=n;i++)
		{
			getchar();
			scanf("%c",&c);
			if(c=='I')
			{
				int t;
				ant++;
				scanf("%d",&a.num);
				if(ant<=m)				//不足m个数直接进去 
				{
					q.push(a);
				}
				else					//大于m时,判断是否大于队列里的最大值 
				{
					t=a.num;
					a=q.top();
					if(t<a.num)			//小于不管,继续 
						continue;
					else
					{
						q.pop();		//新的数大于顶 —最大的,新的数进去,把最小的弹出 
						a.num=t;
						q.push(a);		//始终保持队列里有m个元素,输出时输出最大的(顶元素)即可 
					}
				}
			
			}
			else
			{
				a=q.top();
				printf("%d\n",a.num);
			}
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值