HDU 4006 The kth great number

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4006


The kth great number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 9731    Accepted Submission(s): 3873


Problem Description

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
 

Input

There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number.
 

Output

The output consists of one integer representing the largest number of islands that all lie on one line.
 

Sample Input

  
  
8 3 I 1 I 2 I 3 Q I 5 Q I 4 Q
 

Sample Output

  
  
1 2 3
Hint
Xiao Ming won't ask Xiao Bao the kth great number when the number of the written number is smaller than k. (1=<k<=n<=1000000).
 

Source

 

Recommend

lcy

思路:优先队列的应用。因为k不会变,所以只要用优先队列维护k个数为最大的k个数即可,重载一下小于运算符,让第k大数总是在队首,那么新来的数只要和它比即可,大于就删除队首,插入新数,否则不插入。

附上AC代码:
#include <bits/stdc++.h>
//#pragma comment(linker, "/STACK:102400000, 102400000")
using namespace std;
struct node{
	int num;
	bool operator < (const node & p) const {
		return num > p.num;
	}
};
priority_queue<node> q;
int n, k;

int main(){
	#ifdef LOCAL
	freopen("input.txt", "r", stdin);
	freopen("output.txt", "w", stdout);
	#endif
	while (~scanf("%d%d", &n, &k)){
		while (!q.empty())
			q.pop();
		char op[5];
		node t;
		while (n--){
			scanf("%s", op);
			if (op[0] == 'I'){
				scanf("%d", &t.num);
				if (q.size() < k)
					q.push(t);
				else if (t.num > q.top().num){
					q.pop();
					q.push(t);
				}
			}
			else
				printf("%d\n", q.top().num);
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值