【HDU】-2141-Can you find it?(二分)

Can you find it?

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/10000 K (Java/Others)
Total Submission(s): 23795    Accepted Submission(s): 6032


Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 

Sample Input
  
  
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output
  
  
Case 1: NO YES NO
 
先把a,b数组合并,存入数组d。排序,再用一个n=unique(a,a+n)-a的函数去除掉d里相同的数,因为不去除的话数会有点多,
(函数实际操作:调试表明不同所有数在前,相同在后),n的值改变,变为前面不同的数的个数。
再把c数组里的数过一遍,对d数组二分,可以用已有函数(lower_bound和upper_bound),找到d中与c[i]的和是所求的数,标记,退出。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std; 
int main()
{
	int x,y,z,num=1,ant;
	int a[510],b[510],c[510],d[250010];
	while(~scanf("%d %d %d",&x,&y,&z))
	{
		ant=0;
		for(int i=1;i<=x;i++)
			scanf("%d",&a[i]);
		for(int i=1;i<=y;i++)
		{
			scanf("%d",&b[i]);
			for(int j=1;j<=x;j++)
			{
				d[ant++]=a[j]+b[i];		//将a,b数组合并,记为d 
			}
		}
		sort(d,d+ant);					
		ant=unique(d,d+ant)-d; 		//去除d中相同数,保留不同的,此时d已经重新排序(调试表明不同所有数在前,相同在后),ant的值为前面不同的个数 
		for(int i=1;i<=z;i++)
			scanf("%d",&c[i]);
		printf("Case %d:\n",num++);
		int t;
		scanf("%d",&t);		
		while(t--)
		{
			int m,flag=0;
			scanf("%d",&m);
			for(int i=1;i<=z;i++)
			{
				int l,r,mid;
				l=d[0],r=d[ant-1];				
				int pos=lower_bound(d,d+ant,m-c[i])-d;  //d是递增的数组,找到和m-c[i]相同的值减去首地址返回下标 
				if(d[pos]+c[i]==m)		//d数组必须从0开始,因为用已知函数如果找不到符合的返回b[0],而b[0]=0加c[i]可能与m相同 
				{
					flag=1;
					break;
				}			
			}				
			if(flag)
				printf("YES\n");
			else
				printf("NO\n");	
		}	
	}	
	return 0;
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值