【HDU】-2199-Can you solve this equation?(二分)

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16517    Accepted Submission(s): 7324


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input
  
  
2 100 -4
 

Sample Output
  
  
1.6152 No solution!

二分真心不造说啥,理解题意,写出判断式吧,忧伤......

#include<cstdio>
#include<cmath>
int main()
{
	int t;		
	scanf("%d",&t);
	while(t--)
	{
		double l,r,mid;
		double y,num;
		scanf("%lf",&y);
		num=8*pow(100.0,4)+7*pow(100.0,3)+2*pow(100.0,2)+306;
		if(y<6||y>num)
			printf("No solution!\n");
		else
		{
			l=0,r=100;					
			int size=50;
			while(size--)				//精度不好判断时,用size来代替,多循环几次,size可大可小 
			{
				mid=(l+r)/2;
				double z=8*pow(mid,4)+ 7*pow(mid,3)+2*pow(mid,2)+3*mid+6;	//单调递增 
				if(z==y)
				{
					printf("%.4lf\n",mid);
					break;
				}				
				else if(z>y)		// z>y,mid的值太大了,变小 
					r=mid;
				else
					l=mid;
			}
			printf("%.4lf\n",l);
		}		
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值