POJ1128

52 篇文章 0 订阅
Frame Stacking
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 3416 Accepted: 1107

Description

Consider the following 5 picture frames placed on an 9 x 8 array. 
........ ........ ........ ........ .CCC....

EEEEEE.. ........ ........ ..BBBB.. .C.C....

E....E.. DDDDDD.. ........ ..B..B.. .C.C....

E....E.. D....D.. ........ ..B..B.. .CCC....

E....E.. D....D.. ....AAAA ..B..B.. ........

E....E.. D....D.. ....A..A ..BBBB.. ........

E....E.. DDDDDD.. ....A..A ........ ........

E....E.. ........ ....AAAA ........ ........

EEEEEE.. ........ ........ ........ ........

    1        2        3        4        5   

Now place them on top of one another starting with 1 at the bottom and ending up with 5 on top. If any part of a frame covers another it hides that part of the frame below. 

Viewing the stack of 5 frames we see the following. 
.CCC....

ECBCBB..

DCBCDB..

DCCC.B..

D.B.ABAA

D.BBBB.A

DDDDAD.A

E...AAAA

EEEEEE..






In what order are the frames stacked from bottom to top? The answer is EDABC. 

Your problem is to determine the order in which the frames are stacked from bottom to top given a picture of the stacked frames. Here are the rules: 

1. The width of the frame is always exactly 1 character and the sides are never shorter than 3 characters. 

2. It is possible to see at least one part of each of the four sides of a frame. A corner shows two sides. 

3. The frames will be lettered with capital letters, and no two frames will be assigned the same letter.

Input

Each input block contains the height, h (h<=30) on the first line and the width w (w<=30) on the second. A picture of the stacked frames is then given as h strings with w characters each. 
Your input may contain multiple blocks of the format described above, without any blank lines in between. All blocks in the input must be processed sequentially.

Output

Write the solution to the standard output. Give the letters of the frames in the order they were stacked from bottom to top. If there are multiple possibilities for an ordering, list all such possibilities in alphabetical order, each one on a separate line. There will always be at least one legal ordering for each input block. List the output for all blocks in the input sequentially, without any blank lines (not even between blocks).

Sample Input

9
8
.CCC....
ECBCBB..
DCBCDB..
DCCC.B..
D.B.ABAA
D.BBBB.A
DDDDAD.A
E...AAAA
EEEEEE..

Sample Output

EDABC

Source

拓扑排序+DFS搜索排序答案。
先遍历找出出现字母的最大最小x和最大最小y,然后对于出现过的字母进行遍历,对应边框上出现其他字母,用链式前向星从当前字母到其他字母连一条边,然后拓扑深搜答案。
#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
using namespace std;
const int maxm=31*31;
int n,m,total_edge;
int head[27],indegree[27],queue[27];
struct node
{
    int to;
    int next;
} edges[maxm];
struct point
{
    int maxx,maxy;
    int minx,miny;
} p[27];
void addedge(int u,int v)
{
    edges[total_edge].to=v;
    edges[total_edge].next=head[u];
    head[u]=total_edge++;
}
char map[31][31];
bool flag[27];
bool sign[27];
int sum;
void topsort_dfs(int u,int t)
{
queue[t]=u;
if(t==sum-1)
{
    for(int i=0;i<sum;i++)
    cout<<char('A'+queue[i]);
    cout<<endl;
    return ;
}
for(int k=head[u];k!=-1;k=edges[k].next)
indegree[edges[k].to]--;
for(int i=0;i<26;i++)
if(!indegree[i]&&flag[i]&&!sign[i])
{
    sign[i]=1;
    topsort_dfs(i,t+1);
    sign[i]=0;
}
for(int k=head[u];k!=-1;k=edges[k].next)
indegree[edges[k].to]++;
}
int main()
{
    while(cin>>n>>m)
    {
        memset(head,-1,sizeof(head));
        memset(flag,0,sizeof(flag));
        memset(indegree,0,sizeof(indegree));
        memset(queue,-1,sizeof(queue));
        total_edge=sum=0;
        for(int i=0; i<n; i++)
            for(int j=0; j<m; j++)
            {
                cin>>map[i][j];
                if(map[i][j]!='.')
                {
                    int tmp=map[i][j]-'A';
                    if(!flag[tmp])
                    {
                        sum++;
                        p[tmp].maxx=p[tmp].minx=i;
                        p[tmp].maxy=p[tmp].miny=j;
                        flag[tmp]=1;
                    }
                    else
                    {
                        p[tmp].maxx=max(p[tmp].maxx,i);
                        p[tmp].minx=min(p[tmp].minx,i);
                        p[tmp].maxy=max(p[tmp].maxy,j);
                        p[tmp].miny=min(p[tmp].miny,j);
                    }
                }
            }
        for(int i=0; i<26; i++)
        {
            memset(sign,0,sizeof(sign));
            if(flag[i])
            {
                char c='A'+i;
                for(int si=p[i].minx; si<=p[i].maxx; si++)
                    for(int sj=p[i].miny; sj<=p[i].maxy; sj++)
                        if(si==p[i].minx||si==p[i].maxx||sj==p[i].miny||sj==p[i].maxy)
                        {
                            if(map[si][sj]!=c&&map[si][sj]!='.')
                            {
                                int tmp=map[si][sj]-'A';
                                if(sign[tmp]) continue;
                                sign[tmp]=1;
                                indegree[tmp]++;
                                addedge(i,tmp);
                            }
                        }
            }
        }
        int tmp=0;
        int que[27];
        for(int i=0;i<26;i++)
        if(!indegree[i]&&flag[i])
            que[tmp++]=i;
        for(int i=0;i<tmp;i++)
        {
            memset(sign,0,sizeof(sign));
            sign[que[i]]=1;
            topsort_dfs(que[i],0);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值