HDU-2717 Catch That Cow

HDU-2717 Catch That Cow

Time Limit: 5000/2000 MS (Java/Others)
Memory Limit: 32768/32768 K (Java/Others)

Problem Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
-Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
-Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input
5 17
Sample Output
4
Hint :he fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.


题目网址:http://acm.hdu.edu.cn/showproblem.php?pid=2717

分析

题意:给出一个起点,一个终点,然后根据要求的方法来到达终点,求出所用的最短的时间

思路:这类题做多了就会感到非常简单,这题还没有一点套路,直接广搜的方法一用就求出来了。

代码
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;
int m,n,temp[100001];
struct node
{
    int i,pre;
};
int BFS(int x,int y)
{
    queue<node>it;
    memset(temp,0,sizeof(temp));
    node o,e;
    e.i=x;
    e.pre=0;
    temp[e.i]=1;
    it.push(e);
    if (x==y)
        return 0;
    while (!it.empty())
    {
        e=it.front();
        it.pop();
        for (int i=0;i<3;i++)
        {
            if (i==0)
                o.i=e.i+1;
            if (i==1)
                o.i=e.i-1;
            if (i==2)
                o.i=e.i*2;
            o.pre=e.pre+1;
            if (o.i==y)
                return o.pre;
            if (o.i<0||o.i>100000||temp[o.i])
                continue;
            temp[o.i]=1;
            it.push(o);
        }
    }
}
int main()
{
    while (~scanf("%d %d",&m,&n))
    {
        printf("%d\n",BFS(m,n));
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值