HDU-1009 FatMouse' Trade

HDU-1009 FatMouse’ Trade

Time Limit : 2000/1000ms (Java/Other)
Memory Limit : 65536/32768K (Java/Other)

Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
Sample Output
13.333
31.500


题目网址:http://acm.hdu.edu.cn/showproblem.php?pid=1009

分析

题意:我先来说一下题意吧。FatMouse准备了M磅的猫食,准备跟守卫仓库的猫进行交易,仓库有N个房间。第i间房间包含J [I]磅的JavaBeans,并且需要F [i]磅的猫粮,求可以获得的最大JavaBeans数量。

思路:很水的一个贪心题,只需要将每个仓库的性价比按照从大到小排列一下,依次进行交易,直到将M磅猫食全部交换。排序的话可以用sort函数,再写一个自定义排序方法即可。

代码
#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;
struct node
{
    int v;
    int w;
}dp[1005];
int cmp(node a,node b)
{
    return (a.v*1.0)/a.w>(b.v*1.0)/b.w;
}
int main()
{
    int M,N;
    while (scanf("%d %d",&M,&N),M!=-1||N!=-1)
    {
        for (int i=0;i<N;i++)
        {
            scanf("%d %d",&dp[i].v,&dp[i].w);
        }
        sort(dp,dp+N,cmp);
        double sum=0;
        for (int i=0;i<N;i++)
        {
            if (M-dp[i].w>=0)
            {
                sum+=dp[i].v;
                M-=dp[i].w;
            }
            else
            {
                sum+=M*(dp[i].v*1.0)/dp[i].w;
                break;
            }
        }
        printf("%.3lf\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值