记忆化搜索---HDU(1078)

 

 

FatMouse and Cheese--->想来试试就点我

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13972    Accepted Submission(s): 5892

 

Problem Description

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

 

 

Input

There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.
The input ends with a pair of -1's.

 

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected.

 

 

Sample Input

3 1

1 2 5

10 11 6

12 12 7

-1 -1

 

Sample Output

37

题目大意:一个老鼠在n*n的矩阵中,每个位置都有一个奶酪,从(0,0)开始,可以上下左右跑,最多跑k距离,而且跑的第i个位置必须比第i-1个位置的奶酪多,问最多可以吃多少奶酪。

记忆化搜索:采用动态规划或者其思想来搜索。两者结合考虑吧,具体细节看代码。

 

AC代码:

 

#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
int dp[600][600];
int nums[600][600];
int m,n;
int dir[4][2]={0,-1,0,1,-1,0,1,0};//方向数组
int dfs(int a,int b)//dfs搜索
{
    int ans=0;//此处注意应设为局部变量,如果设为全局变量可能会wa,我就wa了好几次==_==||
    if(dp[a][b]) return dp[a][b];
    for(int i=0;i<4;i++)//遍历四个方向
    {
        for(int j=1;j<=n;j++)//此处就是最多走n步,从最少一步开始
        {
            int x=a+j*dir[i][0];//此处和普通的dfs多的就是乘了每步得步数
            int y=b+j*dir[i][1];
            if(x>=0&&x<m&&y>=0&&y<m&&nums[x][y]>nums[a][b])//此处走的下一步奶酪nums[x][y]要
            {                                           //大于上一步nums[a][b].
                ans=max(ans,dfs(x,y));//比较ans和下一次检索得值
            }
        }
    }
    dp[a][b]=ans+nums[a][b];//更新动态规划dp数组的状态
    return dp[a][b];
}
int main()
{
    while(cin>>m>>n&&(m!=-1&&n!=-1))
    {
        memset(dp,0,sizeof(dp));
        memset(nums,0,sizeof(nums));
        for(int i=0;i<m;i++)
            for(int j=0;j<m;j++)
                cin>>nums[i][j];
        cout<<dfs(0,0)<<endl;
    }
    return 0;
}

   大概就是这些吧,因为是初学,具体的有一些也不是特别明白,如果有错误,还请大佬指出批评,蟹蟹。

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值