hdu1078 (记忆化搜索)


Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 
 

Input
There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
The input ends with a pair of -1's. 
 

Output
For each test case output in a line the single integer giving the number of blocks of cheese collected. 
 

Sample Input
 
  
3 1 1 2 5 10 11 6 12 12 7 -1 -1
 

Sample Output
 
  
37

题意就是在n的方阵中,从最左上角,每次横向或纵向走k步,每走一步都要求下一步的数字比上一步的数字更大,从起点开始走到一处求和求到一处,求出最大的和。


此题与滑雪那题有异曲同工之处,但这题更深层次的展现了dp的魅力,看起来像搜索的题若套上了dp功力简直无限大!

这题关键在于是走k步,如何在k步里选择上下左右,而且又要用程序表达出来,所以此题开辟一个数组来记录上下左右的走向是很有必要的,int bb[4][2]={{1,0},{0,1},{-1,0},{0,-1}};在下面程序循环里看这个数组会显得更清晰。其实做过滑雪那题的肯定自然的就会想到递归,然后用数组存状态,这题难就难在存数据大家都会,关键如何上下左右移动而且总共还要移动k步!不多说了,从代码中体会题目精髓:

#include <iostream>
#include <cstdio>
#include <cstring>
#include<algorithm>
using namespace std;
int k,n;
int aa[105][105],w[105][105];
int bb[4][2]={{1,0},{0,1},{-1,0},{0,-1}};
int dp(int a,int b)
{
    if(w[a][b]!=0)return w[a][b];
    int max0=0;//注意max0赋值必须为0!!思考为什么?!(如果不是0,此题必错!)
    for(int i=1;i<=k;i++)
    {
        for(int j=0;j<4;j++)
        {
            int l1=bb[j][0]*i+a;
            int l2=bb[j][1]*i+b;
            if(l1>=0&&l1<n&&l2>=0&&l2<n&&aa[l1][l2]>aa[a][b])
                {
                    if(dp(l1,l2)>max0)
                    max0=dp(l1,l2);
                }
        }
    }
    w[a][b]=max0+aa[a][b];
    return w[a][b];
}

int main()
{
    while(cin>>n>>k&&!(n==-1&&k==-1))
    {
       for(int i=0;i<n;i++)
        for(int j=0;j<n;j++)
        cin>>aa[i][j];
     
       memset(w,0,sizeof(w));
            cout<<dp(0,0)<<endl;
    }
    return 0;
}








转载于:https://www.cnblogs.com/martinue/p/5490578.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值