算法学习【11】—— 1156. Binary tree

题目来源:http://soj.me/1156

1156. Binary tree

Description

Your task is very simple: Given a binary tree, every node of which contains one upper case character (‘A’ to ‘Z’); you just need to print all characters of this tree in pre-order.

Input

Input may contain several test data sets.

      For each test data set, first comes one integer n (1 <= n <= 1000) in one line representing the number of nodes in the tree. Then n lines follow, each of them contains information of one tree node. One line consist of four members in order: i (integer, represents the identifier of this node, 1 <= i <= 1000, unique in this test data set), c (char, represents the content of this node described as above, ‘A’ <= c <= ‘Z’), l (integer, represents the identifier of the left child of this node, 0 <=  l <= 1000, note that when l is 0 it means that there is no left child of this node), r (integer, represents the identifier of the right child of this node, 0 <=  r <= 1000, note that when r is 0 it means that there is no right child of this node). These four members are separated by one space.

      Input is ended by EOF.

      You can assume that all inputs are valid. All nodes can form only one valid binary tree in every test data set.

Output

For every test data set, please traverse the given tree and print the content of each node in pre-order. Characters should be printed in one line without any separating space.

Sample Input

34 C 1 31 A 0 03 B 0 011000 Z 0 031 Q 0 22 W 3 03 Q 0 0

Sample Output

CABZQWQ

Problem Source

ZSUACM Team Member


思路:最多1000个节点,求前序遍历结果。由于输入数据规则,用数组实现是第一个想到的方法。也容易实现。

代码:

#include <iostream>
#include <cstring>

using namespace std;

struct treeNode 
{
	int leftChild;
	int rightChild;
	char data;
};

treeNode arrayTree[1001];

void prePrint(int rootId)
{
	if (rootId != 0)
	{
		cout << arrayTree[rootId].data;
		prePrint(arrayTree[rootId].leftChild);
		prePrint(arrayTree[rootId].rightChild);
	}
}

int main()
{
	int nodeNum;
	treeNode tempInput;
	int inputId;
	int rootId;
	bool nodeExit[1001];
	bool beenChild[1001];

	while (cin >> nodeNum)
	{
		memset(nodeExit, false, sizeof(nodeExit));
		memset(beenChild, false, sizeof(beenChild));

		while (nodeNum--)
		{
			cin >> inputId >> tempInput.data >> tempInput.leftChild >> tempInput.rightChild;
			arrayTree[inputId] = tempInput;
			nodeExit[inputId] = true;
			beenChild[tempInput.leftChild] = true;
			beenChild[tempInput.rightChild] = true;
		}

		for (rootId = 1; rootId < 1001; rootId++)
		{
			if (nodeExit[rootId] && !beenChild[rootId])
			{
				break;
			}
		}
	
		prePrint(rootId);
		cout << endl;
	}

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
二叉搜索树,也叫二叉查找树(BST,Binary Search Tree),是一种特殊的二叉树。相对于普通的二叉树,它有一个特点:所有左子树的节点都比根节点小,所有右子树的节点都比根节点大。因此,它可以快速地进行查找、插入、删除等操作。 具体来说,二叉搜索树的定义如下: - 节点的左子树中所有节点的值都小于该节点的值。 - 节点的右子树中所有节点的值都大于该节点的值。 - 左右子树也都是二叉搜索树。 如下图所示,就是一个二叉搜索树的例子: ``` 8 / \ 3 10 / \ \ 1 6 14 / \ / 4 7 13 ``` 在这个树中,每个节点都满足左子树的节点值小于该节点的值,右子树的节点值大于该节点的值。比如,节点 3 的左子树是 1 和 6,右子树是 4 和 7,都满足要求。 二叉搜索树的主要操作包括查找、插入和删除。 查找操作可以通过递归或者循环实现。递归实现如下: ``` def search(root, val): if not root or root.val == val: return root if root.val > val: return search(root.left, val) else: return search(root.right, val) ``` 插入操作需要先查找到插入的位置,然后创建一个新节点插入到该位置: ``` def insert(root, val): if not root: return TreeNode(val) if root.val > val: root.left = insert(root.left, val) else: root.right = insert(root.right, val) return root ``` 删除操作比较复杂,需要考虑多种情况。如果要删除的节点只有一个子节点,直接将其子节点替换上来即可。如果要删除的节点有两个子节点,可以找到其右子树中的最小节点(或者左子树中的最大节点)来替换该节点,然后再删除该最小节点(或者最大节点)。 ``` def delete(root, val): if not root: return None if root.val == val: if not root.left: return root.right elif not root.right: return root.left else: # 找到右子树中的最小节点 p = root.right while p.left: p = p.left root.val = p.val root.right = delete(root.right, p.val) elif root.val > val: root.left = delete(root.left, val) else: root.right = delete(root.right, val) return root ``` 需要注意的是,在删除节点时,要保证删除后的树仍然是二叉搜索树。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值