Constructing Roads

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j. 

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2
Sample Output
179

题意:有n个城市,城市标号1~n,已知每两个城市之间连接所需的费用以及已经连通的城市,要使所有的城市连通所需的费用最小。

代码①号(prime):

#include<stdio.h>
#define inf 0x3f3f3f
int n,m,x,y,a[120][120];
void prime()
{
    int i,j,k,mi,cnt=0,sum=0,dis[120],vis[120]={0};
    for(int i=1;i<=n;i++)//dis[i]表示连接城市1到i城市的所需的费用
        dis[i]=a[1][i];
    vis[1]=1;
    cnt++;
    while(cnt<n)//有n个城市,所以总共有n-1次连接就好
    {
        mi=inf;
        for(i=1;i<=n;i++)
        {
            if(vis[i]==0&&dis[i]<mi)
            {
                mi=dis[i];
                j=i;
            }
        }
        vis[j]=1;
        cnt++;
        sum+=dis[j];
        for(k=1;k<=n;k++)
        {
            if(vis[k]==0&&dis[k]>a[j][k])
                dis[k]=a[j][k];
        }
    }
    printf("%d\n",sum);
}
int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
                scanf("%d",&a[i][j]);
        }
        scanf("%d",&m);
        for(int i=0;i<m;i++)
        {
            scanf("%d %d",&x,&y);
            a[x][y]=a[y][x]=0;
        }
        prime();
    }
    return 0;
}

代码②号(kruskal):

#include<stdio.h>
#include<algorithm>
using namespace std;
int n,m,t,x,y,f[12000];
struct node
{
    int x,y,d;
}p[12000];
bool cmp(node a,node b)
{
    return a.d<b.d;
}
int fond(int x)
{
    while(x!=f[x])
        x=f[x];
    return x;
}
void bing(int a,int b)
{
    a=fond(a);
    b=fond(b);
    if(a!=b)
        f[a]=b;
}
void kruskal()
{
    int sum=0,num=0;
    for(int i=0;i<t;i++)
    {
        if(fond(p[i].x)!=fond(p[i].y))
        {
            bing(p[i].x,p[i].y);
            sum+=p[i].d;
            num++;
        }
    }
    printf("%d\n",sum);
}
int main()
{
    while(~scanf("%d",&n))
    {
        t=0;
        for(int i=1;i<=n;i++)
        {
            f[i]=i;
            for(int j=1;j<=n;j++)
            {
                scanf("%d",&p[t].d);
                p[t].x=i;
                p[t].y=j;
                t++;
            }
        }
        scanf("%d",&m);
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&x,&y);//因为城市x到城市y已经连接,所以将它们并到一起
            bing(x,y);
        }
        sort(p,p+t,cmp);
        kruskal();
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值