Constructing Roads(HDU 1102)

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.
We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.
Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output
179

Source
http://acm.hdu.edu.cn/showproblem.php?pid=1102

这道题是简单的最小生成树,可以算是畅通工程的英文版

AC的代码

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define N 110   //最多顶点数
#define MAX 0x3f3f3f3f  //模拟无穷大
int map[N][N];  //存储各顶点间的权值
int flag[N];    //标记是否已纳入树
int dis[N];     //已纳入点和其余各点的最小权值
int prim(int n)        //普利姆函数
{
    int i, j;
    int now;    //记录新纳入的点
    int min;    //记录新纳入的点到其余已纳入的点的最小权值
    int sum = 0;    //最小生成树权值和
    memset(dis, MAX, sizeof(dis));  //初始化dis数组为无穷大
    memset(flag, 0, sizeof(flag));  //初始化flag数组,0表示此点未被纳入
    /*这里随机选取了1号点为初始时被纳入的顶点*/
    for(i = 1; i <= n; i++)
        dis[i] = map[1][i];     //与1号点与其他点的权值存入dis数组
    dis[1] = 0;         //一号点到其本身的权值为0
    flag[1] = 1;        //标记为已纳入

    for(i = 1; i < n; i++){         //除去初始时随机纳入的点还有n-1个点应被纳入
        now = min = MAX;            //初始为无穷大表示两点间无通路
        for(j = 1; j <= n; j++){    //遍历
            if(flag[j] == 0){
                if(dis[j] < min){   //寻找与已纳入各点权值最小的点
                    now = j;
                    min = dis[j];
                }
            }
        }
        if(now == MAX)      //若now等于max,则证明所有与初始时纳入的点连通的点已全被纳入
            break;
        sum += min;     //将找到的点纳入并标记
        flag[now] = 1;
        for(j = 1; j <= n; j++){
            /*
                遍历比较之前纳入点到未纳入点的权值的最小值
                与刚纳入点到未纳入点的权值
                并用dis[j]存储新的最小值
            */
            if(flag[j] == 0)
                if(dis[j] > map[now][j])
                    dis[j] = map[now][j];
        }
    }
    if(i == n)      //若i等于n则证明已经建立最小生成树
        return sum;
    else
        return -1;
}
int main(void)
{
    int i, j, k;
    int n;      //顶点数
    int m;
    while(scanf("%d", &n) != EOF){
        for(i = 1; i <= n; i++)
            for(j = 1; j <= n; j++)
                scanf("%d", &map[i][j]);  //输入i和j之间的距离
        scanf("%d", &m);
        while(m--){
            scanf("%d%d", &i, &j);
            map[i][j] = map[j][i] = 0;  //已建成意味着修建此路还需的花费为0
        }
        if((k = prim(n)) != -1) //调用prim函数
            printf("%d\n", k);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值