HDU1325_Is It A Tree?_并查集

Is It A Tree?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 23289 Accepted Submission(s): 5328

Problem Description
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.
There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.
这里写图片描述

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output
For each test case display the line Case k is a tree." or the lineCase k is not a tree.”, where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8 5 3 5 2 6 4
5 6 0 0
8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0
3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.


这道题在HDU上提交超时,但是在POJ上可以过,应该是要求不同。然而并不知道为什么HDU上会超时。。。
希望有看到这篇文章的大牛能给指点指点。。


我的想法是
1.只能是一个连通图
2.一个节点的父节点是确定的,即不可以复选
3.不能存在环,即父节点不可以相等


#include <cstdio>
#include <cstdlib>
#include <cstring>
using namespace std;

int father[100005];
int flag[100005];

int Find(int a)
{
    int r = a;
    while(r != father[r])
        r = father[r];
    return r;
}

int Union(int x,int y)
{
    int fx = Find(x), fy = Find(y);
    if(fy != y && fy != fx)   //父节点不可复选
        return 0;
    if(fx != fy)
    {
        father[fy] = fx;
        return 1;
    }
    return 0;
}

int main()
{
    int a,b;
    int cnt = 0;
    while((scanf("%d%d",&a,&b)) && (a!=-1 || b !=-1))
    {
        int ans = 1,i,j = 0;
        memset(flag,0,sizeof(flag));

        for(i = 1; i < 100005; i++)
            father[i] = i;

        while(1)
        {
            if(a==0 && b==0)
                break;
            if(ans==1)
                ans = Union(a,b);
            else
                Union(a,b);
            flag[++j] = a;
            flag[++j] = b;
            scanf("%d%d",&a,&b);
        }
        cnt++;
        printf("Case %d is ",cnt);

        if(ans==0)
        {
            printf("not a tree.\n");
        }
        else
        {
            a = Find(flag[1]);
            for(i = 1; i <= j; i++)
            {
                if(Find(flag[i]) != a)
                {
                    ans = 0;
                    break;
                }
            }
            if(ans == 0)
                printf("not a tree.\n");
            else
                printf("a tree.\n");
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值