hdu 1325(Is It A Tree?)

Is It A Tree? (并查集)

Is It A Tree?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21685    Accepted Submission(s): 4886


Problem Description
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.
There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.



In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

 

Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
 

Output
For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
 

Sample Input
  
  
6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1
 

Sample Output
  
  
Case 1 is a tree. Case 2 is a tree. Case 3 is not a tree.
题意:判断是不是树。

题解:1.空树也是树。  2.不成环。  3.只有一个根,也就是有n-1条边。  4.节点入度为1,根的入度为0.

刚开始因为粗心wa了一次,因为不相信自己,看了别人的博客,几乎把自己的思路推翻,以后要细心自信

代码:

#include<cstdio>
#define M 1010
using namespace std;

int fa[M];
int rank[M];
int vis[M];
bool sign[M];
int flag;
	int eg;
void init(){
	for (int i=1;i<M;i++){
		fa[i]=i;
		rank[i]=1;
		vis[i]=0;
		sign[i]=false;
		flag=1;
	}
	
}
int find(int x){
	if (x!=fa[x])
	fa[x]=find(fa[x]);
	return fa[x];
}
void Union(int a,int b){
	a=find(a);//第一次wa在这里,写成了a=fa[a]
	b=find(b);
	if (a!=b){
		fa[b]=a;eg++;//加一条边
	}
	if (a==b) flag=0;//成环
}
int main(){
	int a,b;
	int cas=1;

	int num; 
	while (scanf ("%d %d",&a,&b)!=EOF){
	
		if (a<0 && b<0) break;
		if (a==0 &&b==0){
			printf ("Case %d is a tree.\n",cas++);
			continue;
		}
			init();
		eg = 0;num=0;
		sign[a]=true; sign[b]=true;
		vis[b]++;
		Union(a,b);
		while (scanf ("%d %d",&a,&b)!=EOF){
			if (a==0 && b==0) break;
			sign[a]=true; sign[b]=true;
			vis[b]++;//记录指向的数
			Union(a,b);
		}
		for (int i=1;i<M;i++){
			if (sign[i]) num++;//求节点数
			
		}
		for (int i=1;i<=num;i++)
		if (vis[i]>1){
				flag=0;//一个数不能被指向超过一次
				break;
			}
		if (eg+1==num && flag)
		printf ("Case %d is a tree.\n",cas++);
		else
		printf ("Case %d is not a tree.\n",cas++);
		
		
	}
	return 0;
	
} 
附一篇博客,自己写的有点复杂了

http://blog.csdn.net/a601025382s/article/details/8196477

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值