Catch That Cow

think:
1广度优先搜索(队列思想)
2以结构数组为基础的队列思想
3反思:自己因为vis数组有的初始化位置不对,导致runtime error.???

hint;
一个农夫的奶牛跑了,他要追上奶牛,奶牛不动,他和奶牛在同一坐标轴上,他可以有3种移动情况,1>他可以向前移动1格2>他可以向后移动1格3>他可以移动目前格数的两倍,三种移动方式花费的时间相同,求最少时间

poj原题链接

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536KB

Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Example Input
5 17

Example Output
4

Hint
poj3278 有链接提示的题目请先去链接处提交程序,AC后提交到SDUTOJ中,以便查询存档。
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
Author

以下为accepted代码

#include <stdio.h>
#include <string.h>
struct node
{
    int Data;
    int size;
}link[200000], ans, t;
int tp, op, vis[200000];
void BFS(int N, int K)
{
    link[tp].Data = N;
    link[tp].size = 0;
    tp++;
    vis[N] = 1;
    while(op < tp)
    {
        ans = link[op++];
        if(ans.Data == K)
        {
            printf("%d\n", ans.size);
            return;
        }
        if(vis[ans.Data+1] == 0 && ans.Data <= K)
        {
            link[tp].Data = ans.Data + 1;
            link[tp].size = ans.size + 1;
            //vis[ans.Data] = 1;
            vis[link[tp].Data] = 1;
            tp++;
        }
        if(vis[ans.Data-1] == 0 && ans.Data > 0)
        {
            link[tp].Data = ans.Data - 1;
            link[tp].size = ans.size + 1;
            //vis[ans.Data] = 1;
            vis[link[tp].Data] = 1;
            tp++;
        }
        if(vis[(ans.Data)*2] == 0 && ans.Data <= K)
        {
            link[tp].Data = (ans.Data)*2;
            link[tp].size = ans.size + 1;
            //vis[ans.Data] = 1;
            vis[link[tp].Data] = 1;
            tp++;
        }
    }
}
int main()
{
    int N, K;
    while(scanf("%d %d", &N, &K) != EOF)
    {
        tp = op = 0;
        memset(vis, 0, sizeof(vis));
        BFS(N, K);
    }
    return 0;
}


/***************************************************
User name: 
Result: Accepted
Take time: 0ms
Take Memory: 1896KB
Submit time: 2017-02-16 20:23:14
****************************************************/

以下为runtime error代码

#include <stdio.h>
#include <string.h>
struct node
{
    int Data;
    int size;
}link[200000], ans, t;
int tp, op, vis[200000];
void BFS(int N, int K)
{
    link[tp].Data = N;
    link[tp].size = 0;
    tp++;
    vis[N] = 1;
    while(op < tp)
    {
        ans = link[op++];
        if(ans.Data == K)
        {
            printf("%d\n", ans.size);
            return;
        }
        if(vis[ans.Data+1] == 0 && ans.Data <= K)
        {
            link[tp].Data = ans.Data + 1;
            link[tp].size = ans.size + 1;
            vis[ans.Data] = 1;
            //vis[link[tp].Data] = 1;
            tp++;
        }
        if(vis[ans.Data-1] == 0 && ans.Data > 0)
        {
            link[tp].Data = ans.Data - 1;
            link[tp].size = ans.size + 1;
            vis[ans.Data] = 1;
            //vis[link[tp].Data] = 1;
            tp++;
        }
        if(vis[(ans.Data)*2] == 0 && ans.Data <= K)
        {
            link[tp].Data = (ans.Data)*2;
            link[tp].size = ans.size + 1;
            vis[ans.Data] = 1;
            //vis[link[tp].Data] = 1;
            tp++;
        }
    }
}
int main()
{
    int N, K;
    while(scanf("%d %d", &N, &K) != EOF)
    {
        tp = op = 0;
        memset(vis, 0, sizeof(vis));
        BFS(N, K);
    }
    return 0;
}


/***************************************************
User name: 
Result: Runtime Error
Take time: 0ms
Take Memory: 0KB
Submit time: 2017-02-16 20:22:20
****************************************************/
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值