sum of power——大数取模

Think:
1大数取模
2相似题目——可考虑快速幂优化

SDUT题目链接

sum of power
Time Limit: 1000MS Memory Limit: 65536KB

Problem Description
Calculate 这里写图片描述 mod (1000000000+7) for given n,m.

Input
Input contains two integers n,m(1≤n≤1000,0≤m≤10).

Output
Output the answer in a single line.

Example Input
10 0

Example Output
10

Hint

Author
“浪潮杯”山东省第八届ACM大学生程序设计竞赛(感谢青岛科技大学)

以下为Accepted代码

#include <bits/stdc++.h>

using namespace std;
#define mod 1000000007///预定义

int main()
{
    long long sum, sun;
    int n, m, i, j;
    while(scanf("%d %d", &n, &m) != EOF)
    {
        sum = 0;
        for(i = 1; i <= n; i++){
            sun = 1;
            for(j = 0; j < m; j++){
                sun = (sun * i) % mod;///及时取模,避免超出存储范围
            }
            sum = (sum + sun) % mod;///及时取模,避免超出数据范围
        }
        printf("%lld\n", sum);
    }
    return 0;
}


/***************************************************
User name: 
Result: Accepted
Take time: 0ms
Take Memory: 192KB
Submit time: 2017-05-11 21:19:26
****************************************************/
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值