3899 sum of power

9 篇文章 0 订阅
7 篇文章 0 订阅

sum of power

Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description

Calculate  mod (1000000000+7) for given nm.

Input

Input contains two integers n,m(1≤n≤1000,0≤m≤10).

Output

Output the answer in a single line.

Sample Input
10 0
Sample Output
10
Hint

#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std ; 


int main()
{
    long long n , m ; 
    cin>>n>>m;
        long long result = 0 ; 
        for(int i=1 ; i<= n ; i++)
{
            long long num = 1 ; 
            for(int j=1 ; j<=m ; j++)
{
                num = num * i %1000000007 ; 
            }
            result = (result + num ) % 1000000007 ; 
        }
        cout<<result<<endl;  
    return 0; 
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值