M - Catch That Cow POJ - 3278

Think:
1BFS
2反思:注意数组越界+注意标记走过的点
3C++中的STL的queue练习

M - Catch That Cow POJ - 3278

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

以下为Runtime Error代码——数组越界

#include <cstdio>
#include <cstring>
#include <queue>

using namespace std;

struct node{
    int x;
    int step;
}a, b;

int v[240000];

void BFS(int n, int m);

int main(){
    int n, m;
    while(scanf("%d %d", &n, &m) != EOF){
        BFS(n, m);
    }
    return 0;
}
void BFS(int n, int m){
    queue<struct node> q;
    a.x = n;
    a.step = 0;
    q.push(a);
    v[n] = 1;
    while(!q.empty()){
        a = q.front();
        q.pop();
        if(a.x == m){
            printf("%d\n", a.step);
            break;
        }
        if(a.x < m && v[a.x+1] == 0){
            b.x = a.x + 1;
            b.step = a.step + 1;
            q.push(b);
            v[b.x] = 1;
        }
        if(a.x >= 1 && v[a.x-1] == 0){
            b.x = a.x - 1;
            b.step = a.step + 1;
            q.push(b);
            v[b.x] = 1;
        }
        if(v[a.x*2] == 0){
            b.x = a.x*2;
            b.step = a.step + 1;
            q.push(b);
            v[b.x] = 1;
        }
    }
}

以下为Accepted代码

#include <cstdio>
#include <cstring>
#include <queue>

using namespace std;

struct node{
    int x;
    int step;
}a, b;

int v[240000];

void BFS(int n, int m);

int main(){
    int n, m;
    while(scanf("%d %d", &n, &m) != EOF){
        BFS(n, m);
    }
    return 0;
}
void BFS(int n, int m){
    queue<struct node> q;
    a.x = n;
    a.step = 0;
    q.push(a);
    v[n] = 1;
    while(!q.empty()){
        a = q.front();
        q.pop();
        if(a.x == m){
            printf("%d\n", a.step);
            break;
        }
        if(a.x < m && v[a.x+1] == 0){
            b.x = a.x + 1;
            b.step = a.step + 1;
            q.push(b);
            v[b.x] = 1;
        }
        if(a.x >= 1 && v[a.x-1] == 0){
            b.x = a.x - 1;
            b.step = a.step + 1;
            q.push(b);
            v[b.x] = 1;
        }
        if(a.x <= m && v[a.x*2] == 0){
            b.x = a.x*2;
            b.step = a.step + 1;
            q.push(b);
            v[b.x] = 1;
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值