poj3278 <BFS/DFS>

the reason of falure:1、记得不能给数组A[负数]赋值,会running error

2、定义数组应该在头文件那#define MAXN 9999

然后定义的全局变量

thinking:1、<BFS>从8个方向都探索,如果有W则给打上标记,放入队列.

2、<DFS>从8个方向都搜索,当有W则打上标记,马上从这个打上标记的W开始搜索下一个

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side

BFS代码:

#include <iostream>
#include <queue>
#define MAXN 200
using namespace std;
struct ttt{
	int x,y;
};

int dr[]={-1,0,1,0,1,-1,-1,1};
int dc[]={0,1,0,-1,1,-1,1,-1};
int n,m;
char map1[MAXN][MAXN];
bool walked[MAXN][MAXN];

void fun(ttt b){
	queue<ttt>q;
	ttt a;
	q.push(b);
	while(!q.empty()){
		b=q.front();
		q.pop();
		for(int i=0;i<8;i++){
		a.x=b.x+dr[i];
		a.y=b.y+dc[i];	
		if(a.x<=m&&a.x>=1&&a.y<=n&&a.y>=1&&walked[a.y][a.x]==0&&map1[a.y][a.x]=='W'){
			walked[a.y][a.x]=1;
			q.push(a);
		}
			}
}
}
int main(){
	freopen("in.txt","r",stdin);
	freopen("out.txt","w",stdout);
	cin >> n >> m;
	int i,j,k,l;
	ttt a;
	int sum=0;
	for(i=1;i<=n;i++)
		for(j=1;j<=m;j++)
		cin >> map1[i][j];
		for(i=1;i<=n;i++)
			for(j=1;j<=m;j++)
				if(walked[i][j]==0&&map1[i][j]=='W'){
					walked[i][j]=1;
					sum++;
					a.x=j;
					a.y=i;
					fun(a);
				}
				cout << sum << endl;
		return 0;
}
DFS代码:
#include <iostream>
#define MAXN 300
using namespace std;
char map1[MAXN][MAXN];
int n,m;
bool walked[MAXN][MAXN];
int dr[]={-1,0,1,0,1,-1,-1,1};
int dc[]={0,1,0,-1,1,-1,1,-1};

void dfs(int i,int j){
	if(i<1||i>n||j<1||j>m)return;
	for(int k=0;k<8;k++){
	int a=i+dr[k];
	int b=j+dc[k];
	if(map1[a][b]=='W'&&walked[a][b]==0){
		walked[a][b]=1;
		dfs(a,b);
	}
}
}
int main(){
	freopen("in.txt","r",stdin);
	freopen("out.txt","w",stdout);
	cin >> n >> m;
	int i,j,k,l;
	int sum=0;
	for(i=1;i<=n;i++)
		for(j=1;j<=m;j++)
		cin >> map1[i][j];
		for(i=1;i<=n;i++)
			for(j=1;j<=m;j++)
			if(walked[i][j]==0&&map1[i][j]=='W'){
				walked[i][j]=1;
				dfs(i,j);
				sum++;			
			}
			cout << sum << endl;
			return 0;
		}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值