二分法 POJ3273

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M 
Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

题目大意:

给出n个数据代表每天的花费,现将其任意分成m组,求满足使得每组花费最小的最大花费。

题解:

朴素穷举肯定超时,因此要使用二分法枚举答案。由题意,可行的花费介于单日花费的最大值与所有天数花费之和之间,我们再判断一下区间中值是否满足将天数分成m组的要求即可。

代码:

#include <iostream>
#include <cstdio>
#include <algorithm>

using namespace std;
int n,m,a[100005];
bool check(int x)
{
	int sum=0,k=1;//初始将所有天数视为一组
	for(int i=0;i<n;i++)
		{
			sum+=a[i];
			if(sum>x)
				{
					k++;
					sum=a[i];
				}
		}
	return k<=m;
}

int solve(int a,int b)
{
	int l=a,r=b,tmp=0,mid;
	while(l<=r)
		{
			mid=l+(r-l)/2;//此处注意下界不为0,不能写成(l+r)/2。
			if(check(mid))
				{
					tmp=mid;
					r=mid-1;
				}
			else
				l=mid+1;
		}
	return tmp;
}

int main()
{
	while(~scanf("%d%d",&n,&m))
		{
			int max=-1,sum=0;
			for(int i=0;i<n;i++)
				{
					scanf("%d",&a[i]);
					if(a[i]>max)	max=a[i];
					sum+=a[i];
				}
			printf("%d\n",solve(max,sum));
		}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值