二分法典型应用(二)最大化最小值 POJ2456 Aggressive cows

10 篇文章 0 订阅

问题描述:
Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,…,xN (0 <= xi <= 1,000,000,000).
His C (2 <= C <= N) cows don’t like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?
Input

* Line 1: Two space-separated integers: N and C
* Lines 2..N+1: Line i+1 contains an integer stall location, xi 

Output

* Line 1: One integer: the largest minimum distance 

Sample Input

5 3
1
2
8
4
9

Sample Output

3

分析:

这类的最大化最小值或者最小化最大值的问题,通常用二分搜索法就能够很好解决,并且效率很高。

我们定义C(d)为安排牛的位置使得最近的两头牛的距离不小于d。
那么我们就可以将问题变成求满足C(d)的最大的d。这样二分法就能很快地解决了。但是首先需要用贪心的思想把数据处理一下。

  • 对牛舍的位置x进行升序排序
  • 把第一头牛放入x0的牛舍
  • 如果第i头牛放入xj的话,第i+1头牛就要放入满足xj+d<=xk的最小的xk中。

那么我们这样解决这个问题:假设需要放两头牛。刚开始所有的牛舍都是空的,把牛舍的距离做个升序排序,将第一头牛放到第一个牛舍中并定住不变,然后往接下的牛舍放第二头牛进行判断,第一次如果x1-x0 >= d,则符合条件,否则就继续到剩下的牛舍进行判断,如果都走完了都放不了第二头牛,则这个距离就是不符合的。用二分法取距离进行判断。

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 100000+1;
const int INF = 1000000000;
int x[maxn];
int N,M;
/*判断函数*/
bool C(int d)
{
    int last = 0;
    for(int i=1; i<M; i++)
    {
        int crt = last + 1;
        while(crt<N && x[crt] - x[last] < d)
        {
            crt++;
        }
        if(crt == N) return false;//走到牛舍尽头都放不了,则失败
        last = crt;//此牛已放好
    }
    return true;
}
/*二分法*/
void solve()
{
    sort(x, x+N);
    int lb = 0, ub = INF;
    while(ub - lb > 1)
    {
        int mid = (lb + ub) / 2;
        if(C(mid)) lb = mid;
        else ub = mid;
    }
    printf("%d\n",lb);
}

int main()
{
    scanf("%d%d",&N,&M);
    for(int i=0; i<N; i++)
    {
        scanf("%d",&x[i]);
    }
    solve();
    return 0;
}
  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值