hdu1024 Max Sum Plus Plus

Problem Description

Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^

 

Input

Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 ... Sn.
Process to the end of file.

 

Output

Output the maximal summation described above in one line.

 

Sample Input

1 3 1 2 3

2 6 -1 4 -2 3 -2 3

Sample Output

6 8

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define INF 0x3f3f3f3f
#define ll long long

using namespace std;

const int maxn=1e6+10;

ll dp[2][maxn];
ll a[maxn];
int m,n;

int main()
{
	while(~scanf("%d%d",&m,&n))
		{
			ll ans=-1e15;//负数尽量取大一点
			int t=1;
			int i,j,k;
			for(int i=1;i<=n;i++)
				{
					scanf("%lld",&a[i]);
					dp[0][i]=dp[1][i]=0;
				}
			for(int i=1;i<=m;i++)
				{
					dp[t][i]=dp[1-t][i-1]+a[i];
					ll Max=dp[1-t][i-1];
					for(int j=i+1;j<=n+m-1;j++)
						{
							Max=max(Max,dp[1-t][j-1]);
							dp[t][j]=max(dp[t][j-1],Max)+a[j];
						}
					t=1-t;
				}
			t=1-t;
			for(int j=m;j<=n;j++)
				if(ans<dp[t][j])
				ans=dp[t][j];
			printf("%lld\n",ans);
		}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值