Cleaning Shifts - POJ 2376 贪心

Cleaning Shifts
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12574 Accepted: 3257

Description

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T. 

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval. 

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

* Line 1: Two space-separated integers: N and T 

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2

题意:给出总长度和若干条线段,问最少选择多少条线段能够覆盖所有整数点【注意:只需覆盖整数点


思路:先把线段按照起始点升序排序,遍历时每次比较当前线段的起始点和前一条线段的起始点,如果当前线段起始点更早说明前一条线段可以被更新,否则的话进入新一轮的取线段【感觉不好解释呢还是看代码的注释吧


#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<string>
#include<cstring>
#include<algorithm>
#include<map>
#include<queue>
#include<stack>
#define INF 0x777777
#define MAXN 25010
using namespace std;
struct node
{
	int s,e;
}cow[MAXN];

bool cmp(node a,node b)
{
		return a.s<b.s;
}
int main()
{
	int n,T;
	scanf("%d%d",&n,&T);
	for(int i=1;i<=n;i++)
		scanf("%d%d",&cow[i].s,&cow[i].e);
	sort(cow+1,cow+1+n,cmp);
	if(cow[1].s>1) {
		printf("-1\n");return 0;
	}
	int start=0,end=0,cnt=0; //注意start和end的初始条件
	for(int i=1;i<=n;i++){
		if(cow[i].s<=start)		//如果小于等于start只需更新end 
			end=max(end,cow[i].e);
		else{	//大于start则增加计数,此时保证取的是end最远的线段 
			cnt++;
			start=end+1;	//只需从end的下一个点开始 
			if(cow[i].s<=start)
				end=max(end,cow[i].e);	//不要忘记更新end 
			else{
				printf("-1\n");
				return 0;
			}
		}
		if(end>=T) break;
				
	}
	if(end>=T)
		printf("%d\n",cnt);
	else
		printf("-1\n");
		
	
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值