[POJ2376]Cleaning Shifts

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T. 

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval. 

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.
Input
* Line 1: Two space-separated integers: N and T 

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.
Output
* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.
Sample Input
3 10
1 7
3 6
6 10
Sample Output
2
Hint
This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed. 

INPUT DETAILS: 

There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10. 

OUTPUT DETAILS: 

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.

题意:给出区间[ 1,T ]和N个小区间,要求用尽可能少的小区间覆盖区间[ 1,T ],输出最少的小区间数量;若不能覆盖,输出-1。

思路:贪心。

具体:令begin为当前未被覆盖的区间起点。

            贪心策略:选取包含点begin的区间中右端点最大的那个;若不存在包含begin的区间,输出-1。

证明:因为begin为未被覆盖的区间起点,所以begin一定要被小区间覆盖,将最优解中覆盖begin的小区间命名为区间X。

            以下使用剪贴技术证明。

            若存在包含begin的小区间Y( Y != X )使最终所需的小区间数少于原最优解,那么Y一定包含了X之后的某些小区间,

            即Y的右端点大于X的右端点,与贪心策略矛盾,得证。

#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
const int N=25010;
int n, T, sum, start=1, end;
struct node{ int s, e; }cow[N];

bool cmp( node a, node b ) {
	return a.s<b.s;
}

int main() {
	scanf( "%d%d", &n, &T );
	for( int i=1; i<=n; i++ ) {
		scanf( "%d%d", &cow[i].s, &cow[i].e );
		end=max( end, cow[i].e );
		cow[i].e++;
	}
	sort( cow+1, cow+n+1, cmp );
	if( 1<cow[1].s || end<T ){ printf( "-1\n" ); return 0; }
	end=0;
	for( int i=1; i<=n; ) {
		bool flg=0;
		while( i<=n && cow[i].s<=start ) {
			end=max( end, cow[i].e );
			i++; flg=1;
		}
		if( !flg ){ printf( "-1\n" ); return 0; }
		sum++;
		if( end>T ) break;
		start=end;
	}
	printf( "%d\n", sum );
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值