PAT(Advanced Level)1103. Integer Factorization

1103. Integer Factorization (30)

时间限制
1200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The K-P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K-P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (<=400), K (<=N) and P (1<P<=7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n1^P + ... nK^P

where ni (i=1, ... K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122 + 42 + 22 + 22 + 12, or 112+ 62 + 22 + 22 + 22, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a1, a2, ... aK } is said to be larger than { b1, b2, ... bK } if there exists 1<=L<=K such that ai=bi for i<L and aL>bL

If there is no solution, simple output "Impossible".

Sample Input 1:
169 5 2
Sample Output 1:
169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2
Sample Input 2:
169 167 3
Sample Output 2:
Impossible
    一个简单的深搜,当时做天梯训练的时候做了一下,没做出来,感觉好坑的题,回来重新敲一遍就过了,谁知道当初我做了啥。
#include <bits/stdc++.h>
using namespace std;
int n,m,k,flag = 0,ans = 0;
int a[500],b[500];
void dfs(int d,int sum,int cnt,int t){
    if(sum>n)return;
    if(cnt==m){
        if(sum==n){
        flag = 1;
        if(t>ans){
            ans = t;
            for(int i = 0;i < m;i++)
                b[i] = a[i];
        }
        }
        return;
    }
    for(int i = d;i >= 1;i--){
            a[cnt] = i;
            dfs(i,sum+pow(i,k),cnt+1,t+i);
    }
}
int main()
{
    cin>>n>>m>>k;
    int temp = sqrt(n);
    dfs(temp,0,0,0);
    if(!flag)cout<<"Impossible"<<endl;
    else {
        cout<<n<<" = ";
        for(int i = 0;i < m;i++){
            cout<<b[i]<<"^"<<k;
            if(i!=m-1){
                cout<<" + ";
            }
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值