PAT 1103 Integer Factorization

The K−P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K−P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (≤400), K (≤N) and P (1<P≤7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n[1]^P + ... n[K]^P

where n[i] (i = 1, ..., K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 12​2​​+4​2​​+2​2​​+2​2​​+1​2​​, or 11​2​​+6​2​​+2​2​​+2​2​​+2​2​​, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a​1​​,a​2​​,⋯,a​K​​ } is said to be larger than { b​1​​,b​2​​,⋯,b​K​​ } if there exists 1≤L≤K such that a​i​​=b​i​​ for i<L and a​L​​>b​L​​.

If there is no solution, simple output Impossible.

Sample Input 1:

169 5 2

Sample Output 1:

169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2

Sample Input 2:

169 167 3

Sample Output 2:

Impossible

这道题之前做过,不过这次做的时候超时了,提交之前的代码有一个测试点结果错误,看来是测试点数据更新了。

解题思路:最后是求一个正整数序列,使得n1^p+n2^p+...=n,并且如果有多个结果,则选择因数和最大的;如果仍有多个相同的,就选择序列比较最大的(及从第一个数开始比较,直到出现不同,并判断大小)。对于每一个因数,有两种选择,一是将当前因数加入到暂存的结果序列中,另一种是不加入。在递归中,如果序列长度与总和分别小于k与n,则继续递归(选择与不选择当前数);如果序列长度等于k,并且总和等于n,则判断当前得到的序列是不是比之前的结果更好,其余的情况继续递归不会得到答案,因此其余的情况停止递归。

第一次提交有一个测试点超时,之后把dfs参数中的tmpans变为全局变量后AC了。

#include <cstdio>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;

int n, k, p;
vector<int> facs, ans, tmpans;
int maxfacsum = 0;

bool isGreatSeq(vector<int> &l, vector<int> &r) {
	for (int i = 0; i < l.size(); ++i) {
		if (l[i] != r[i])
			return l[i] > r[i];
	}
	return false;
}

void dfs(int curfacindex, int facsum, int sum) {
	if (curfacindex >= facs.size()) {
		return;
	}
	else {
		if (tmpans.size() <= k && sum <= n) {
			if (tmpans.size() < k) {
				if (sum < n) {
					dfs(curfacindex + 1, facsum, sum);
					int curfac = facs[curfacindex];
					tmpans.push_back(curfac);
					facsum += curfac;
					sum += (int)pow(curfac, p);
					dfs(curfacindex, facsum, sum);
					tmpans.pop_back();
				}
			}
			else {
				if (sum == n) {
					if (facsum > maxfacsum) {
						maxfacsum = facsum;
						ans = tmpans;
					}
					else if (facsum == maxfacsum && isGreatSeq(tmpans, ans)) {
						ans = tmpans;
					}
				}
			}
		}
	}
}


int main()
{
	scanf("%d%d%d", &n, &k, &p);
	for (int i = 1; pow(i, p) <= n; ++i)
		facs.push_back(i);
	sort(facs.begin(), facs.end(), [](int &l, int &r)->bool {
		return l > r;
	});
	dfs( 0, 0, 0);
	if (ans.empty()) {
		printf("Impossible\n");
	}
	else {
		printf("%d =", n);
		int i = 0;
		for (i = 0; i < ans.size() - 1; ++i)
			printf(" %d^%d +", ans[i], p);
		printf(" %d^%d\n", ans[i], p);
	}
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值