pta_邻接表创建无向图

仅记录数据结构——pta作业

题目

采用邻接表创建无向图G ,依次输出各顶点的度。

输入格式:

输入第一行中给出2个整数i(0<i≤10),j(j≥0),分别为图G的顶点数和边数。
输入第二行为顶点的信息,每个顶点只能用一个字符表示。
依次输入j行,每行输入一条边依附的顶点。

输出格式:

依次输出各顶点的度,行末没有最后的空格。

输入样例:

5 7
ABCDE
AB
AD
BC
BE
CD
CE
DE

输出样例:

2 3 3 3 3

思路

  1. 即无向图邻接表的建立过程

代码


#include<iostream>
using namespace std;
typedef struct lb{
    char data;
    struct lb* next=NULL;
}lb,*plb;
typedef struct Node{
    char data;
    int degree=0;
    plb etail=NULL;
}Node,*pNode;
int main(){
    int v,e;
    //cout<<"input v and e:";
    cin>>v>>e;
    char a,b;
    pNode G = new Node[v];
    //cout<<"input data:";
    for(int i = 0; i < v; i++){
        cin>>G[i].data;
    }
    //cout<<"input edge:";
    for(int i = 0; i < e; i++){
        
        cin>>a>>b;
        G[a-'A'].degree++;
        G[b-'A'].degree++;
        plb temp = new lb;
        temp->data = b;
        if(G[a-'A'].etail==NULL){
            G[a-'A'].etail = temp;
        }
        else{
            plb p = G[a-'A'].etail;
            while(p->next!=NULL){
                p = p->next;
            }
            p->next = temp;
        }
    }
    for(int i = 0; i < v-1; i++){
        cout<<G[i].degree<<" ";
    }
    cout<<G[v-1].degree<<endl;
    system("pause");
    return 0;
}

  • 6
    点赞
  • 8
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值