仅记录个人数据结构pta作业——岛屿数量
题目
给你一个由 1(陆地)和 0(水)组成的n*m的二维网格,请你计算网格中岛屿的数量num。
岛屿总是被水包围,并且每座岛屿只能由水平方向或竖直方向上相邻的陆地连接形成。例如
例 | 例 | 例 |
---|---|---|
0 | 0 | 0 |
0 | 1 | 0 |
0 | 0 | 1 |
此为两个岛屿
此外,你可以假设该网格的四条边均被水包围。1<=n,m<=100
输入格式:
第一行中给出网格长宽n,m
接下来的n行表示网格情况
输出格式:
岛屿个数num
输入样例:
在这里给出一组输入。例如:
4 5
1 1 0 0 0
1 1 0 0 0
0 0 1 0 0
0 0 0 1 1
输出样例:
在这里给出相应的输出。例如:
3
思路
- 从(0,0)开始,若为1,则采用BFS,上下左右若有为1,则继续搜索,直到该陆地所有单元被检索完全
- 检索过的地方visit为true
- 检索完一个岛屿,记录
- 直到所有地方都访问过
代码
#include<iostream>
#include<vector>
#include<queue>
using namespace std;
typedef struct Node{
int index;
int visit=0;
}Node,*pNode,**ppNode;
typedef struct land{
vector<int> area;
struct land* next=NULL;
}land,*pland;
void creatland(pNode &iland,int num,queue<pland> &dao,int a,int b){
queue<int> q;
pland temp= new land;
q.push(num);
temp->area.push_back(num);
while(!q.empty()){
int top = q.front();
q.pop();
if(top-b){
if(iland[top-b].index==1&&iland[top-b].visit==0){
q.push(top-b);
iland[top-b].visit=1;
temp->area.push_back(top-b);
}
}
if(top+b<a*b){
if(iland[top+b].index==1&&iland[top+b].visit==0){
q.push(top+b);
iland[top+b].visit=1;
temp->area.push_back(top+b);
}
}
if(top%b){
if(iland[top-1].index==1&&iland[top-1].visit==0){
q.push(top-1);
iland[top-1].visit=1;
temp->area.push_back(top-1);
}
}
if(top%b!=b-1){
if(iland[top+1].index==1&&iland[top+1].visit==0){
q.push(top+1);
iland[top+1].visit=1;
temp->area.push_back(top+1);
}
}
}
dao.push(temp);
}
int main(){
int a,b;
cin>>a>>b;
pNode iland = new Node[a*b];
for(int i = 0;i < a*b;i++){
cin>>iland[i].index;
}
int count = 0;
queue<pland> dao;
for(int i = 0;i < a;i++){
for(int j = 0;j < b;j++){
if(iland[i*b+j].index==1&&iland[i*b+j].visit==0){
creatland(iland,i*b+j,dao,a,b);
count++;
}
}
}
cout<<count<<endl;
system("pause");
return 0;
}