PAT-A1155 Heap Paths 题目内容及题解

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

题目大意

题目给出完全二叉树的层序遍历,要求输出该完全二叉树从左到右的所有从根节点到叶节点的路径,并且判断完全二叉树的属性(大根堆/小根堆/非堆)并输出。

解题思路

  1. 初始化并读入完全二叉树,并由前两个元素比较猜测其大/小根堆属性;
  2. 通过DFS寻找并按照题目要求输出所有从根节点到叶节点的遍历,并判断其是否符合堆的性质;
  3. 根据检查结果按照题目要求的格式输出完全二叉树的属性并返回零值。

代码

#include<stdio.h>
#define maxn 1010

int trace[15];
int Max,Flag;
int seq[maxn],N;

void Init(){
    int i;
    scanf("%d",&N);
    for(i=1;i<=N;i++){
        scanf("%d",&seq[i]);
    }
    if(seq[1]>seq[2]){
        Max=1;//大根堆 
    }else{
        Max=0;
    }
    Flag=1;
}

void DFS(int n,int depth){
    int i;
    if(n>N){
        return;
    }
    trace[depth]=seq[n];
    if(2*n>N){
        printf("%d",trace[0]);
        for(i=1;i<=depth;i++){
            if(Flag){
                if(Max){
                    if(trace[i]>trace[i-1]){
                        Flag=0;
                    }
                }else{
                    if(trace[i]<trace[i-1]){
                        Flag=0;
                    }
                }
            }
            printf(" %d",trace[i]); 
        }
        printf("\n");
        return;
    }
    DFS(2*n+1,depth+1);
    DFS(2*n,depth+1);
}

void Check(){
    if(Flag==0){
        printf("Not Heap\n");
    }else{
        if(Max==1){
            printf("Max Heap\n");
        }else{
            printf("Min Heap\n");
        }
    }
}

int main(){
    Init();
    DFS(1,0);
    Check();
    return 0;
}

运行结果

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值