Joseph

Joseph

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3001 Accepted Submission(s): 1694
 
Problem Description
The Joseph\\\\\\\'s problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.
 
Input
The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.
 
Output

            The output file will consist of separate lines containing m corresponding to k in the input file.
 
Sample Input
3
4
0
 
Sample Output
5
30
题目大意:一共有2k个人,前k个好人和后k个坏人,每隔m个人挑一个人出来,
知道最后一个坏人被挑出来为止,这中间不能有好人被挑出
数据量较小,可以通过暴力枚举
#include <iostream>
#include<string.h>
using namespace std;
int main(){
    int a[20],ans[20];
    int i,n,k,m;
    memset(a,0,sizeof(a));
    for(i=1;i<=14;i++)
    {
        int mm=2*i;
        m=1;
        for(k=1;k<=i;k++)
        {
            a[k]=(a[k-1]+m-1)%(mm+1-k);
//从第一个人开始数            if(a[k]<i)
            {
                k=0;
                m++;
            }
        }
        ans[i]=m;
    }
    int nnn;
    while(cin>>n)
    {
        if(n==0)break;
        cout<<ans[n]<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值