Max Sum

Max Sum

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2121 Accepted Submission(s): 798
 
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
 
Sample Output
Case 1:
14 1 4

Case 2:
7 1 6
 
     
题目大意:最大字段和问题   加了一个下标  即输出 这个字段和的其实位置
注意看样例中csae 2  最大和是7  是从1-6 也就是说前面存在一段和等于0 也加上  具体看代码
#include<iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
int main()
{
    int a[100001],st,end;
    int n,i,j,s,max,sum;
    int t,tt;
    int cc=1;
    cin>>t;
    int ttt=t;
    while(t--)
    {
        cin>>n;
        st=1;
        tt=1;
        sum=0;
        memset(a,0,sizeof(a));
        max=-1000000;
        for(i=0;i<n;i++)
        {
           scanf("%d",&a[i]);
            sum+=a[i];
            if(sum>max)
            {
                max=sum;
                st=tt;
                end=i+1;//i从0 开始的
            }
            if(sum<0)  // 舍弃 更新当前开始位置+1
            {
                 tt=i+2;
                sum=0;
            }
        }
        cout<<"Case "<<cc<<":"<<endl;
        cout<<max<<" "<<st<<" "<<end<<endl;
        cc++;
        if(t)cout<<endl;//输出陷阱
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值