FatMouse's Speed

FatMouse's Speed

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1443 Accepted Submission(s): 719
 
Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
 
Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.
 
Output

            Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that 

W[m[1]] < W[m[2]] < ... < W[m[n]]

and 

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.
 
Sample Input
6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900
 
Sample Output
4
4
5
9
7
题目大意:最长上升子序列问题,好多老鼠,给你老鼠的重量和速度,说明老鼠的重量越大速度越慢,在输出最长子序列的同时,
输出序号,也就是记录下路径
思路也很简单,首先根据老鼠的重量排序,再根据老鼠的速度排序(没排也过了),接下来就是最长子序列或下降问题了,在求解中,记录下
老鼠的序号即可。
 
         
#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
struct mouse
{
    int w;//重量 速度 序号
    int s;
    int num;
}m[1001];
int a[1001];
int b[1001];
int c[1001];
int cmp(mouse a,mouse b)
{
//    if(a.w==b.w) return a.s>b.s;
    return a.w<b.w;
}
int main()
{
    int i=1,j,n=1,flag=-1;
    while(scanf("%d %d",&m[i].w,&m[i].s)!=EOF)
    {
        m[i].num=i;
        i++;
    }
    n=i;
    sort(m,m+n,cmp);
    int max=0;
    for(i=1;i<n;i++)
    {
        a[i]=1;
	b[i]=-1;
        for(j=i-1;j>=1;j--)
            if(m[i].w>m[j].w&&m[i].s<m[j].s&&a[j]+1>a[i])
            {
                a[i]=a[j]+1;
                b[i]=j;        //记录序号
            }
        if(a[i]>max)
        {
            max=a[i];
            flag=i;      //记录末尾的传说中最肥的那一只老鼠
        }
    }
    printf("%d\n",max);
    int t=0;
    while(flag!=-1)
    {
        c[t]=flag;
        flag=b[flag];
        t++;
    }
    for(i=t-1;i>=0;i--)
        printf("%d\n",m[c[i]].num);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值