Find The Multiple

Find The Multiple

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 20000/10000K (Java/Other)
Total Submission(s) : 69   Accepted Submission(s) : 29
Special Judge
Problem Description
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
 

Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
 

Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
 

Sample Input
  
  
2 6 19 0
 

Sample Output
  
  
10 100100100100100100 111111111111111111
题目意思:给出一个200以内的数 求一个只由1和0组成的能被他整除的数
思路:深搜
因为深搜会一直往下进行 所以要加一个限定条件 就是深度 也就是搜了多少次了
深度只要不太小都可以 做题的时候一直就是想找的限定条件 就是搜索的上限
但是都不行 无奈只能把搜索进行了多少次记录下来了
#include<iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
int n;
int flag;
long long ans;
const long long maxx=0x3f3f3f;
//int deep;
void dfs(long long k,int deep)
{
    if(flag==1)return ;
    else if(deep==19)return ;
    else if(k%n==0)
    {
        flag=1;
        ans=k;
        return ;
        }
    dfs(k*10,deep+1);
    dfs(k*10+1,deep+1);
    }
int main()
{
    int i,j;
    while(cin>>n)
    {
        flag=0;
        //deep=0;
        if(n==0)break;
        dfs(1,0);
        cout<<ans<<endl;
        }
    return 0;
    }

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值