A Knight's Journey

A Knight's Journey

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 188   Accepted Submission(s) : 40
Problem Description
Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
 

Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
 

Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. <br>If no such path exist, you should output impossible on a single line.
 

Sample Input
  
  
3 1 1 2 3 4 3
 

Sample Output
  
  
Scenario #1: A1 Scenario #2: impossible Scenario #3:

A1B3C1A2B4C2A3B1C3A4B2C4

题目大意:给出一个棋盘的规格,问你能否在不重复的情况下吧每一个方格都走一遍,按照国际象棋的走法,东南西北只走日,按字典序输出

思路:广搜记录路径

注意横坐标是字母,纵坐标数字,按照字典序(ABC),以及搜索及时停止,输出,基本问题不大

  • Source Code
    #include<iostream>
    #include<stdio.h>
    #include<string.h>
    using namespace std;
    struct chess
    {
        int x;
        int y;
        };
    int dx[]={-1,1,-2,2,-2,2,-1,1};
    int dy[]={-2,-2,-1,-1,1,1,2,2};
    bool vis[101][101];
    chess ans[101];
    char zimubiao[]={'A','B','C','D','E','F','G','H','I','J','K','L','M','N','O','P','Q','R','S','T','U','V','W','X','Y','Z'};
    int flag;
    int n,m;
     int judge(int x,int y)
     {
         if(x>0&&x<=n&&y>0&&y<=m)
         return 1;
         return 0;
         }
    void dfs(int x,int y,int num)
    {
        int i,j,nextx,nexty;
        ans[num].x=x;
        ans[num].y=y;
        if(flag)return ;
        if(num==n*m)
        {
            for(i=1;i<=n*m;i++)
                {
                    cout<<zimubiao[ans[i].y-1]<<ans[i].x;
                    }
                cout<<endl;
            flag=1;
            return ;
        }
        if(flag)return ;
        for(i=0;i<8;i++)
        {
            nextx=x+dx[i];
            nexty=y+dy[i];
            if(judge(nextx,nexty)==1&&vis[nextx][nexty]==0)
            {
                vis[nextx][nexty]=1;
                dfs(nextx,nexty,num+1);
                vis[nextx][nexty]=0;
                }
            }
        }
    int main()
    {
        int t;
        int c=1,i,j;
        cin>>t;
        for(;c<=t;c++)
        {
            cin>>n>>m;
            memset(vis,0,sizeof(vis));
            flag=0;
            vis[1][1]=1;
            cout<<"Scenario #"<<c<<":"<<endl;
            dfs(1,1,1);
            if(flag==0)cout<<"impossible"<<endl;
            if(c<=t)cout<<endl;
            }
        return 0;
        }

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值