Prime Path

Prime Path

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 71   Accepted Submission(s) : 32
Problem Description
The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices. 
— It is a matter of security to change such things every now and then, to keep the enemy in the dark. 
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know! 
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door. 
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime! 
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds. 
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime. 

Now, the minister of finance, who had been eavesdropping, intervened. 
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound. 
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you? 
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above. 
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.
 

Input
One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).
 

Output
One line for each case, either with a number stating the minimal cost or containing the word Impossible.
 

Sample Input
  
  
3 1033 8179 1373 8017 1033 1033
 

Sample Output
  
  
6 7 0
题目:给两个四位数 (都是素数),每一次只能变一个数字,变换后也得是素数 问第一个数字几下可以变成第二个素数 不能则输出impossible
思路:
bfs 把每个位置每个数字都加入队列,暴力测试,注意千位的变化 ,0 的时候要想到,没注意这点就得wa到死
当然要先打个素数表,如果判断的话容易超时,
  • Source Code
    #include<iostream>
    #include<stdio.h>
    #include<string.h>
    #include<queue>
    #include<string>
    using namespace std;
    void change(int c,char m[])
    {
        m[0]=c/1000;
        m[1]=c%1000/100;
        m[2]=c%100/10;
        m[3]=c%10;
    }
    int vis[10001];
    int a,b;
    int ans;
    int judge(int n)
    {
        int i;
        for(i=2;i<=n/2;i++)
        {
            if(n%i==0)
            {
                return 0;
                }
            }
        return 1;
        }
    int p[10001];
    void findprime()
    {
        for(int i=2;i<10001;i++)
        {
            if(!p[i])
            {
                for(int j=2;i*j<10001;j++)
                    p[i*j]=1;
            }
        }
    }
    struct node
    {
        int x;
        int step;
    };
    int bfs()
    {
        int i,j;
        char m[4];
        queue<node> Q;
        node now,next;
        now.x=a;
        now.step=0;
        Q.push(now);
        vis[a]=1;
        while(!Q.empty())
        {
            now=Q.front();
            Q.pop();
            if(now.x==b)
            {
                ans=now.step;
                return 0;
            }
            for(i=1;i<=4;i++)
            {
                change(now.x,m);
                for(j=0;j<10;j++)
                {
                    if(j==0&&i==1)continue;
                    if(i==1)next.x=j*1000+m[1]*100+m[2]*10+m[3];
                    if(i==2)next.x=m[0]*1000+j*100+m[2]*10+m[3];
                    if(i==3)next.x=m[0]*1000+m[1]*100+j*10+m[3];
                    if(i==4)next.x=m[0]*1000+m[1]*100+m[2]*10+j;
                    if(!p[next.x]&&!vis[next.x])
                    {
                        next.step=now.step+1;
                        vis[next.x]=1;
                        Q.push(next);
                    }
                }
            }
        }
        return 0;
    }
    int main()
    {
        int i,j;
        int t;
        cin>>t;
        p[1]=0;
        p[2]=0;
        p[3]=0;
        findprime();
        //for(i=0;i<=20;i++)
        //cout<<p[i]<<" ";
        while(t--)
        {
            ans=0;
            memset(vis,0,sizeof(vis));
            cin>>a>>b;
            //cout<<judge(a)<<endl;
            //char m[4];change(a);
            //for(i=1;i<5;i++)
            //cout<<m[i]<<endl;
            //cout<<m[2]*100<<endl;
            bfs();
            if(a==b)
            cout<<0<<endl;
            else if(ans!=0)
            cout<<ans<<endl;
            else cout<<"Impossible"<<endl;
        }
        return 0;
    }

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值