POJ2437

Farmer John has a problem: the dirt road from his farm to town has suffered in the recent rainstorms and now contains (1 <= N <= 10,000) mud pools. 

Farmer John has a collection of wooden planks of length L that he can use to bridge these mud pools. He can overlap planks and the ends do not need to be anchored on the ground. However, he must cover each pool completely. 

Given the mud pools, help FJ figure out the minimum number of planks he needs in order to completely cover all the mud pools.
Input
* Line 1: Two space-separated integers: N and L 

* Lines 2..N+1: Line i+1 contains two space-separated integers: s_i and e_i (0 <= s_i < e_i <= 1,000,000,000) that specify the start and end points of a mud pool along the road. The mud pools will not overlap. These numbers specify points, so a mud pool from 35 to 39 can be covered by a single board of length 4. Mud pools at (3,6) and (6,9) are not considered to overlap. 
Output
* Line 1: The miminum number of planks FJ needs to use.
Sample Input
3 3
1 6
13 17
8 12
Sample Output
5
Hint
INPUT DETAILS: 

FJ needs to use planks of length 3 to cover 3 mud pools. The mud pools cover regions 1 to 6, 8 to 12, and 13 to 17. 

OUTPUT DETAILS: 

FJ can cover the mud pools with five planks of length 3 in the following way: 
                   111222..333444555....

                   .MMMMM..MMMM.MMMM....

                   012345678901234567890
题意:有n个坑和长度为l的木板,给出每个坑开始的位置和结束的位置,问最少需要几块木板才可以全部盖住
思路:首先排下序,然后分情况讨论,
计算出每次铺完木板之后的终点,分为超过下一个坑的起点和未超过,还有就是直接跳过了下一个
第一种则end变为铺完木板之后的位置
第二种则是下一个的起点
三则跳过
接下来就是计算需要几块木板的问题   对于长度len刚好整除l的则 取其相除的值
另一类取其整除之后的值+1
   
   
  • Source Code
    #include<iostream>
    #include<stdio.h>
    #include<string.h>
    #include<algorithm>
    using namespace std;
    struct node
    {
        long long l;
        long long r;
        }a[10001];
    bool cmp(node A,node B)
    {
        if(A.l==B.l)return A.r<B.r;
        else
        return A.l<B.l;
        }
    int main()
    {
        int i,j;
        int n,l;
        while(cin>>n>>l)
        {
            for(i=0;i<n;i++)
            cin>>a[i].l>>a[i].r;
            sort(a,a+n,cmp);
            //for(i=0;i<n;i++)
            //cout<<a[i].l<<" "<<a[i].r<<endl;
            int ans=0,end=0;
            int len,num;
            for(i=0;i<n;i++)
            {
                if(end>=a[i].r)
                continue;
                if(end>a[i].l)
                {
                    len=a[i].r-end;
                    if(len%l==0)
                    num=len/l;
                    else num=len/l+1;
                    end+=num*l;
                    ans+=num;
                    }
                else
                {
                    len=a[i].r-a[i].l;
                    if(len%l==0)
                    num=len/l;
                    else num=len/l+1;
                    end=a[i].l+num*l;
                    ans+=num;
                    }
                }
            cout<<ans<<endl;
            }
        return 0;
        }

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值